Jet Central Turbines - Artes Jet Jet Central Turbines formerly the Artes Jet forum

Falcon sputtering at idle

Reply

Old 06-27-2011, 12:36 PM
  #1  
hyperdyne
Senior Member
Thread Starter
My Feedback: (6)
 
Join Date: Oct 2003
Location: Superior, CO
Posts: 397
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Falcon sputtering at idle

Tried to reach Eric but no answer and his mailbox is full. Hopefully someone can help me out here.

I have a falcon that was part of a plane buy. Had a real old ECU in it (shrink wrapped). Engine would flameout easily during ground tests. And it always had a bad "motorboating" low growl when accelerating from idle through 65k rpm. Above 65k it seemed fine. Eric told me that was the way the falcon was. Per his suggestions, I blew air through the fuel line in an attempt to clean injector nozzles. Seemed to help.

Recently I replaced the ECU with the newest offering, upgraded to ceramic plug, new gas valve - hoping this would help. Relearned radio settings, did engine ramping test for ECU learning, although Eric said that wasnt necessary any longer? Yesterday did more ground tests. Used new mixed fuel. On idle the engine sputters quite a bit, everytime it does this big blue flame exits the engine. Even when motorboating sometimes up through 65k rpm blue flame sputters. Above 65k engine runs just fine. Pump around 65 at idle. Temp is fine around 600 C, but can reach high 600 when sputters and blue flame erupt.

Anybody have any ideas? I tried to raise the idle rpm up from 36k to 41k with no improvment. This engine has been more trouble than its worth...






hyperdyne is offline  
Reply With Quote
Old 06-28-2011, 03:11 AM
  #2  
George
My Feedback: (57)
 
Join Date: Dec 2001
Location: Va Beach, VA
Posts: 2,988
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

Sounds like there is a problem with the fuel ring not properly atomizing the fuel at idle. And yes, Eric is correct, the Falcon ALWAYS "motor-boated" (as you call it) when advancing the throttle.

Keep trying Eric, he'll answer, but I bet that engine needs to be sent in for service.
George is offline  
Reply With Quote
Old 06-28-2011, 06:24 AM
  #3  
joeflyer
My Feedback: (47)
 
Join Date: Dec 2001
Location: Plymouth, MI
Posts: 2,782
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

My Falcon never did that.

George is on the right track. I had that problem on my old Ram500. The fuel gets too hot in the fuel ring and some of it vaporizes before getting to the injectors. At higher rpm, and higher fuel flow, the fuel doesn't stay in the ring long enough or get hot enough to vaporize. The fix is to wrap some thin insulation around the fuel ring to keep the fuel cooler at low rpm. A new, smaller diameter ring could also fix the problem.

Joe
joeflyer is offline  
Reply With Quote
Old 06-28-2011, 08:50 AM
  #4  
hyperdyne
Senior Member
Thread Starter
My Feedback: (6)
 
Join Date: Oct 2003
Location: Superior, CO
Posts: 397
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

ok thanks for the insight.

I will most likely send the engine back to Eric. It will be easier for the experts to figure this out.

Regards,
Jim
hyperdyne is offline  
Reply With Quote
Old 06-29-2011, 06:16 AM
  #5  
RCISFUN
My Feedback: (44)
 
RCISFUN's Avatar
 
Join Date: Apr 2002
Location: Erie, PA
Posts: 6,317
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

ORIGINAL: hyperdyne

ok thanks for the insight.

I will most likely send the engine back to Eric. It will be easier for the experts to figure this out.

Regards,
Jim
Eric is most likely to on his way to KY Jets, he is driving by himself and he told me that he was going to take three days to get there for a Friday arrival

p.s. I don't recall my old Falcon doing that either...
RCISFUN is offline  
Reply With Quote
Old 06-29-2011, 07:47 AM
  #6  
phjoker
Senior Member
My Feedback: (4)
 
phjoker's Avatar
 
Join Date: Sep 2005
Location: Vernon, NJ
Posts: 869
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

My Falcon never did that, but I have seen two others ones that have.
phjoker is offline  
Reply With Quote
Old 06-29-2011, 09:02 AM
  #7  
hyperdyne
Senior Member
Thread Starter
My Feedback: (6)
 
Join Date: Oct 2003
Location: Superior, CO
Posts: 397
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

Was their any consensus or findings on what caused the other two falcons to behave that way?

hyperdyne is offline  
Reply With Quote
Old 07-01-2011, 03:03 AM
  #8  
George
My Feedback: (57)
 
Join Date: Dec 2001
Location: Va Beach, VA
Posts: 2,988
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Falcon sputtering at idle

Well, mine did that on acceleration from day one, but always ran great! Nothing wrong, just an indication that you are spooling just about as fast as the engine can handle. I had a VERY early production model too, so don't know if that was a factor. I heard and seen other Falcons do it as well.
George is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service