Jet Central Turbines - Artes Jet Jet Central Turbines formerly the Artes Jet forum

ECU bad?

Reply

Old 05-12-2012, 06:45 PM
  #1  
afterburner
Thread Starter
My Feedback: (18)
 
afterburner's Avatar
 
Join Date: Jun 2002
Location: New City, NY
Posts: 3,021
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default ECU bad?

Had one flight on my F-15 today since Kentucky last year and on the second flight attempt the engine(Eagle)wouldn't start. Data terminal showed that the temp was 000. Thought that the thermocouple bit the dust but tonight I hooked up my ECU from a Rabbit to the Eagle and it showed the ambient temp and went up a degree or two when I put my finger on the thermocouple. So I'm assuming the ECU is bad. Eric, can I just send the ECU to you for a replacement? Is there anything else to try? First in Flight jet rallyis two weeks away and when I left my house this morning I had three jets and now I'm down to one flyable and the F-15. Thanks.

Marty
afterburner is offline  
Reply With Quote
Old 05-13-2012, 05:37 AM
  #2  
BluFox
My Feedback: (10)
 
Join Date: Jan 2002
Location: North Port, FL
Posts: 1,107
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ECU bad?

Marty:

need the serial number for your Super Eagle. I will have one programmed and sent. Need complete shipping address also. Please call me Monday with a cc for core ECU to be returned. You can give the suspect ECU to me at FIF.

Please email me the serial number of the Super Eagle @ jetartessales@aol.com

Regards,
Eric

from Joe Nall venue
BluFox is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service