Jet Central Turbines - Artes Jet Jet Central Turbines formerly the Artes Jet forum

Super eagle glow plug and gas settings

Reply

Old 11-01-2015, 03:50 PM
  #1  
jetspud
Thread Starter
 
jetspud's Avatar
 
Join Date: Dec 2001
Location: shreveport , LA
Posts: 1,092
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Super eagle glow plug and gas settings

I sent my super eagle off to get serviced. When i got it back it had a new cremic plug that had the glow plug setting at 15 v. I still use the 7.4 nimh battery so there is no way it will get the new plug hot enough.

So what is or was the setting for the regular glow plug? I put the setting at 1.5 volt but it still would not light off the gas. I think the setting has to be higher than 1.5 volts but dont want to blow the plug since i blew one when it was set at 15v

Next what is the gas(propane) setting?

thanks
david
jetspud is offline  
Reply With Quote
Old 11-02-2015, 06:34 AM
  #2  
rcjets12
My Feedback: (21)
 
rcjets12's Avatar
 
Join Date: Apr 2002
Location: Palm Bay , FL
Posts: 380
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

If you have the ceramic glow you must use that higher setting. I know the battery is only 7.4 but is has to do with the way the ECU reads the V for the glow plug. If you lower it to 1.5v it will never light the ceramic plug
rcjets12 is offline  
Reply With Quote
Old 11-02-2015, 04:43 PM
  #3  
jetspud
Thread Starter
 
jetspud's Avatar
 
Join Date: Dec 2001
Location: shreveport , LA
Posts: 1,092
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hi Jose

I lowered the voltage to go back to the regular glow plug because the new ceramic plug was not lighting the gas off. So i can try the ceramic again and put the voltage back to 15v but just incase it does not work. I would like to just use the regular old glow plug so i can fly. Thats why I was asking about the voltage for the regular glow plug. At 1.5v the regular glow plug lights up but doesnt get hot enough to light the gas. I

Thanks
David
jetspud is offline  
Reply With Quote
Old 11-03-2015, 04:51 PM
  #4  
rcjets12
My Feedback: (21)
 
rcjets12's Avatar
 
Join Date: Apr 2002
Location: Palm Bay , FL
Posts: 380
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by jetspud View Post
Hi Jose

I lowered the voltage to go back to the regular glow plug because the new ceramic plug was not lighting the gas off. So i can try the ceramic again and put the voltage back to 15v but just incase it does not work. I would like to just use the regular old glow plug so i can fly. Thats why I was asking about the voltage for the regular glow plug. At 1.5v the regular glow plug lights up but doesnt get hot enough to light the gas. I

Thanks
David
You can try to raise the V a little. I have had issues with glow plugs just depends on which type you are using. I know that cold plugs take a little more. Also make sure that you pull out the filiments enough.
rcjets12 is offline  
Reply With Quote
Old 03-15-2016, 04:36 AM
  #5  
heytex
My Feedback: (11)
 
Join Date: May 2003
Location: summerville, SC
Posts: 41
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Jose what's brand & number glow plug go in super eagel thanks.need ceramic plug are you going to the jet event in s.c.april or n.c.may
heytex is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service