Jet Central Turbines - Artes Jet Jet Central Turbines formerly the Artes Jet forum

Cheetah SP Glow Bad message

Reply

Old 10-10-2018, 06:50 PM
  #1  
turnnburn
Thread Starter
My Feedback: (49)
 
Join Date: Jul 2002
Location: Arlington, TX
Posts: 940
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Cheetah SP Glow Bad message

Tried to fly my Cheetah SP this eve.. Won't start or even try to start. Message on the readout says ..."Glow Bad" and then on a subsequent screen it said "Glow Plug Disconnected".

I assume this is NOT something I can fix or look into ???

Where do I send it and do I need to send anything besides the engine itself ?
turnnburn is offline  
Reply With Quote
Old 10-10-2018, 06:55 PM
  #2  
Mannyr
 
Join Date: Jul 2018
Posts: 23
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hi Turnnburn,

The Glow Plug needs to be changed.
It's not something that you can do by yourself.
Here are the instructions for the service/repair.
https://drive.google.com/file/d/0B7t...ncFBTNm5z/view

If you have any questions, you can send me an email to manny@aeropanda.com

Best regards,

Manny Rodriguez
JetCentral USA
Mannyr is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service