JetCat Turbine Direct Support Ask your JetCat questions here for the experts that know them. MrMatt and Bob Wilcox will field your inquiries.

Hot exhaust shooting out sides of turbine

Reply

Old 08-09-2018, 06:47 PM
  #1  
bRandom
Thread Starter
 
Join Date: Sep 2013
Location: St. Louis, Missouri
Posts: 58
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hot exhaust shooting out sides of turbine

Exhaust is shooting out the side where the exhaust cone butts against the body of the p140rx. It is melting all my pneumatic hoses. Should I just shield everything from the heat, or is this a more involved problem?
thanks
bRandom is offline  
Reply With Quote
Old 08-10-2018, 02:56 PM
  #2  
mr_matt
My Feedback: (10)
 
mr_matt's Avatar
 
Join Date: Dec 2001
Location: Oak Park, CA,
Posts: 10,244
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by bRandom View Post
Exhaust is shooting out the side where the exhaust cone butts against the body of the p140rx. It is melting all my pneumatic hoses. Should I just shield everything from the heat, or is this a more involved problem?
thanks
Sounds like something has worked loose. It is OK to get some oil seepage and a bit of smoke but I have never had hot gas shoot out, something is wrong.
mr_matt is offline  
Reply With Quote
Old 08-11-2018, 09:40 AM
  #3  
bRandom
Thread Starter
 
Join Date: Sep 2013
Location: St. Louis, Missouri
Posts: 58
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Sorry perhaps hot gas was the worst possible choice of words. Basically I mean Heat or possibly some occasional Flames if you see it in the dark are escaping between the exhaust cone mounting rim and motor body where it's bolted on the back and it looks like the edges are not perfectly flush all the way around the motor I'll have to take a picture and post it.
bRandom is offline  
Reply With Quote
Old 08-11-2018, 05:58 PM
  #4  
rcflyguy_26
My Feedback: (8)
 
rcflyguy_26's Avatar
 
Join Date: Mar 2002
Location: Findlay, OH
Posts: 482
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Your exhaust nozzle to bell entrance sounds wrong... pictures please
rcflyguy_26 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service