Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 22 of 22

Thread: 120SE Issue


  1. #1

    Join Date
    Nov 2004
    Location
    Norfolk, UNITED KINGDOM
    Posts
    61
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    120SE Issue

    I've had my SE from new, it's got 8hrs runtime and is flown in a Boomerang XL.

    The other week I felt it was down on power, so I landed and checked the fuel system over, couldn't find a fault.

    Got home and stripped the engine out to find 3 fins from the compresser missing. The turbine has had a FOD guard all it's life and flies off clean flat tarmac here in the UK. I assumed that FOD must have got in somewhere.

    As a loyal Jetcat customer I sent the turbine off to Germany for repairs. To give Jetcat credit they have turned it around and done the upmost to get it returned to me quickly so I can fly in the UK show circuit. I have paid in full for the repairs.

    However...............

    Upon stripping the motor down I noticed that there was a dent in the FOD screen, not from the assumed side but from inside out as if something came out from the engine.

    I have now been informed that there may have been issues with the diffuser breaking up on SE versions at around 8hrs (this is word of mouth and not confirmed.)

    Can anyone shed some light on this, i have paid for this repair when perhaps it should have been under warranty.

    Obviously this has left a very sour taste in my mouth with regard to Jetcat, apart from their service which was excellent.

    Hopefully someone can shed some light on this situation.

    Cheers

    Steve


  2. #2

    Join Date
    Nov 2004
    Location
    Norfolk, UNITED KINGDOM
    Posts
    61
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    That's 3 PM's i've got so far.

    Anyone wish to go public??

    I think I need to have a quiet chat with Jetcat Germany.

    Steve

  3. #3

    RE: 120SE Issue

    Steve,
    I'm very interested in whats going on, I have 2 new P160SE and a P60SE coming tomorrow, would really like to know if there is anything to this ?

    Regards,
    Carsten
    Carsten Groen

  4. #4

    Join Date
    Jun 2004
    Location
    Canyon Lake, TX
    Posts
    778
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    .

  5. #5

    Join Date
    Jan 2004
    Location
    BeirutBeirut, LEBANON
    Posts
    999
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Very much concerned about this issue also as i have recently bought a P-120SE and a Titan SE and they are both still in the box.
    Hope to hear some good news soon.

    Regards.

  6. #6
    KC36330's Avatar
    Join Date
    Apr 2006
    Location
    Enterprise, AL
    Posts
    5,935
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue


    ORIGINAL: Bob R2

    ...........I was not running a fod screen - however, the air intake is above the wing and well protected
    it never ceases to amaze me how you can spend 3 grand on a turbine and neglect to put a $30 FOD screen on it. it doesn't matter where the intakes are there are countless ways for FOD to get in the intake, a servo screw can back out.............. then the $30 you saved by NOT buying a FOD screen don't even cover the postage for the turbine to be sent in for repairs.

  7. #7
    josecilurzo's Avatar
    Join Date
    Oct 2006
    Location
    SAO JOSE DO RIO PRETO-SP, BRAZIL
    Posts
    653
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    We have 3 JETCATs ( P-120SE NEW, 2 P-70 ), well, where this jetcat? I believe that something would have to speak to us.
    Our P-70 is fine and perfect in functioning, run absolutely ok, and the assistance of MR MATT is very quick and enlightening, BUT, I`m worried about that, I hope a feedback from JETCAT GERMANY OR USA.

    JOSE [sm=75_75.gif]

  8. #8

    Join Date
    Jun 2004
    Location
    Canyon Lake, TX
    Posts
    778
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    .

  9. #9
    KC36330's Avatar
    Join Date
    Apr 2006
    Location
    Enterprise, AL
    Posts
    5,935
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    shall i enlighten you even further with the fact that YOU are the one with a FOD'd turbine on its way in for repairs???

  10. #10

    Join Date
    Nov 2004
    Location
    Norfolk, UNITED KINGDOM
    Posts
    61
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Cheers for the posts so far guys.

    I sent an e-mail to Jetcat Germany last night and this has been sent to Max in Germany to comment further on the situation.

    Cheers bob r2, sounds similar to mine although I did have a FOD screen which meant the blade couldn't escape and probably got ingested back into the turbine.

    I've request a full report as to the fault and what has been changed.

    I'm sure Jetcat will take a serious look at the situation.

    I'll report back after the w/end as Max is at a show in Germany this w/end.

    Steve

  11. #11

    Join Date
    Aug 2002
    Location
    yesville, CT
    Posts
    10
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    .

  12. #12
    josecilurzo's Avatar
    Join Date
    Oct 2006
    Location
    SAO JOSE DO RIO PRETO-SP, BRAZIL
    Posts
    653
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Ok KC,

    I`m stay with you, I speak since 2002 that to use the FOD he is vital for a turbine, and looks at the cost the FOD!!!!

    jose[8D]

  13. #13
    josecilurzo's Avatar
    Join Date
    Oct 2006
    Location
    SAO JOSE DO RIO PRETO-SP, BRAZIL
    Posts
    653
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Hi Steve,

    when the JETCAT to report you, please inform to us what happened.

    I hope that everything finishes well.

    regards

    jose [8D]

  14. #14
    KC36330's Avatar
    Join Date
    Apr 2006
    Location
    Enterprise, AL
    Posts
    5,935
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    ORIGINAL: Snoblobber


    Kc you just dumb-thumbed your p-70 into the ground.
    It amazes me, you can post over 2000 times in less than two years.
    Your just another poser

    oh great slobber of knobs do you need a FOD screen for your mouth??

  15. #15

    Join Date
    Jun 2004
    Location
    Canyon Lake, TX
    Posts
    778
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    .

  16. #16
    DelGatoGrande's Avatar
    Join Date
    Mar 2004
    Location
    ATHENS, , GREECE
    Posts
    2,606
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue





    i run p120se 's!
    no promblems.please keep an upper class to our forum resist to insult and let jetcat get back to us!

    if you are new you must learn that jetcat is one of the top if not the top on turbines.

    Bob R2 what you did is not nice.

    you should clear this with manufactor first and then go on public.this way rest jet guys will take you more seriusly.

    take care
    Best Regards George
    www.rcjet.gr \"props are for boats\"

  17. #17

    Join Date
    Jun 2004
    Location
    Canyon Lake, TX
    Posts
    778
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    I have been running JetCats for a couple of years. I agree that they are one of the top turbines, and it was not my intent to insult them. However, Steve had an incident that was similar to what I experienced, he asked for comments from other owners, so I responded.

    I have deleted my previous posts as I do not wish to further disrupt the JetCat forum.

    Regards,
    Bob

  18. #18

    Join Date
    Nov 2004
    Location
    Norfolk, UNITED KINGDOM
    Posts
    61
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Back to the topic.

    Thanks for the PM bob.

    I hope this is not seen as a dug at Jetcat, all I wanted was some feedback if other have had this problem. As I said I'm happy with the Jetcat service I have had. It's just this underlying feeling that I didn't cause this turbine to breakup.

    I've happily paid for the repair........but should I of.

    At the end of the day I'm glad it's repaired and it'll be on it's way back to me on Monday.

    However I still have that slight itch in the back of my neck giving me doubt it was my fault.

    I hope this clarifies the situation.

    Steve

  19. #19
    DelGatoGrande's Avatar
    Join Date
    Mar 2004
    Location
    ATHENS, , GREECE
    Posts
    2,606
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Bob dont get me whrong/im sorry if i got "angry"//i always read all feedbacks and like them!

    like me you also i guess have pay lots of money for our crazy hobby.. corect?[8D]

    so please dont delete your posts.its not good friend.

    all i ask is to just take it easy and come at mr.matt place when he will get back here and find a threat with 20 replies and out of control maybe!

    i think jetcat will never let no one down///take care my kind of people


    Best Regards George
    www.rcjet.gr \"props are for boats\"

  20. #20

    Join Date
    Aug 2002
    Location
    yesville, CT
    Posts
    10
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue





    I have deleted my previous posts as I do not wish to further disrupt the JetCat forum.


  21. #21
    mr_matt's Avatar
    Join Date
    Dec 2001
    Location
    Oak Park, CA,
    Posts
    9,174
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Hello,

    Sorry about your troubles. I am glad you are in contact with Max, you are now talking to one of the top guys in engineering at JetCat directly, I am sure he will be able to help you with all of the info you need.

    Regards,
    Matt

  22. #22

    Join Date
    Nov 2004
    Location
    Norfolk, UNITED KINGDOM
    Posts
    61
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 120SE Issue

    Issue resolved with a new turbine at very little cost, built up to the latest SE spec.

    Steve


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:34 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.