JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

The AR8000 DSM2 & DSMX Receivers do not flash when power is supplied via batt & ESC

Reply

Old 12-04-2016, 06:41 AM
  #1  
indigo731
Junior Member
Thread Starter
My Feedback: (4)
 
Join Date: Nov 2003
Location: Dallas, TX
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default The AR8000 DSM2 & DSMX Receivers do not flash when power is supplied via batt & ESC

I recently got a DX6/Receiver AR610 and a DX8/Receiver/AR8000 DSMX. I can not bind either of my (2) AR8000 DSMX or DSX2 to the DX8 transmitter. I fly airplanes nothing else. The receivers never flash LED signal alerting to entering bind mode. My planes are mostly electric so there is a certain way to bind them to Spektrum transmitters, but the DX8 is got me baffled. Neither of the (2) receivers will enter the bind mode when power is applied via ESC and battery.

I did bind the plane to my DX6 receiver AR610, but it want even flash with the AR8000. Help!
indigo731 is offline  
Reply With Quote
Old 12-04-2016, 09:41 AM
  #2  
fizzwater2
My Feedback: (60)
 
Join Date: Aug 2004
Location: Paola, KS
Posts: 2,762
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

two things -

at the risk of being obvious, are you using the bind plug in the proper slot when applying power to the RX?

2) The AR8000 receivers require a satellite receiver to be connected in order to bind and operate. Are you using the satellite receivers with them? If so, perhaps the interconnect wires between the sat and main RX are bad?
fizzwater2 is offline  
Reply With Quote
Old 12-04-2016, 12:35 PM
  #3  
indigo731
Junior Member
Thread Starter
My Feedback: (4)
 
Join Date: Nov 2003
Location: Dallas, TX
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thank you very for your reply. I did have the bind plug in the correct slot. "Bind/Batt". I did find out what was wrong.

1) The wiring for the DX6/AR610 places yellow wire on top, brown on bottom when in bind mode or just plugging in servo plugs. On the DX8/AR800-DSMX or 2 wiring is reversed. Brown wire on top, yellow on bottom. As soon as I reconnected this the receiver began flashing displaying bind mode. Proceeded bind process and had success binding both receivers to DX8 transmitter.
indigo731 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service