JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

AR636 Driving me mad!

Reply

Old 03-19-2017, 03:43 AM
  #1  
g4uvz
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default AR636 Driving me mad!

I am having terrible problems ...It started with the Crescendo1 which I was using to teach a junior on..it just stopped working ..the AR636A would apparently rebind but the servo outputs remained dead even though the light was on. I sent it back to HH in the UK and they provided me with a new 636 I then had to buy the Iphone cable to program to the Crescendo...did this Ok however the receiver will now not bind to my DX9! To make things worse the UK HH office has now shut down and the German office ignores emails.. I am wondering if a firmware upgrade will sort the issue? but that means buying yet another cable! I am a retired electronics engineer and can normally sort these issues ..but this on has be beaten at the moment...
g4uvz is offline  
Reply With Quote
Old 03-21-2017, 04:49 AM
  #2  
g4uvz
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

OK I have sorted the first problem! The receiver will not bind if it is not in the correct orientation...that is to say if it sits in the model with the Spektrum label uppermost then it MUST be in that plane when you bind...then all is fine.
g4uvz is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service