JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

DX6 Display Issue?

Reply

Old 03-28-2017, 09:06 AM
  #1  
harleymhs
Thread Starter
 
Join Date: Feb 2006
Location: woodside, NY
Posts: 14
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default DX6 Display Issue?

Hey Guys, I just received a NEW DX6 radio.. I noticed when I power it up, the display reads DX6 and it is not clear... I also noticed that most DX6's on youtube shows the Spektrum bars on start up... Is that an old firmware maybe ? And by looking at the photo here is the display bad? Thanks

!
Attached Thumbnails Click image for larger version

Name:	IMG_0651.JPG
Views:	62
Size:	483.1 KB
ID:	2207447  
harleymhs is offline  
Reply With Quote
Old 03-28-2017, 06:40 PM
  #2  
BelAirBob
 
Join Date: Mar 2004
Location: Bel Air, MD
Posts: 451
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

There should be an adjustment for contrast in the menu. If that does not solve it, just call Horizon

Let us know what happens

Bob
BelAirBob is offline  
Reply With Quote
Old 03-29-2017, 01:18 PM
  #3  
AndyKunz
 
Join Date: Jun 2005
Location: White Heath, IL
Posts: 2,756
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The logo on the screen is supposed to be two different gray tones. Your picture shows that nicely.

We got rid of the rising bars shortly after the DX6G2 was released. All our radios have splash screens like this now.

To get to the contrast quickly, hold down CLEAR and BACK as you power up. This gives the Raw Input screen. You can adjust the contrast with the roller. When you click, is saves it.

Andy
AndyKunz is offline  
Reply With Quote
Old 03-30-2017, 03:23 AM
  #4  
harleymhs
Thread Starter
 
Join Date: Feb 2006
Location: woodside, NY
Posts: 14
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thank you for clearing that up!
harleymhs is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service