JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

Spektrum Dx4e Motor No throttle ESC

Reply

Old 02-23-2018, 10:38 AM
  #1  
tsargeaunt
Junior Member
Thread Starter
 
Join Date: Feb 2018
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Spektrum Dx4e Motor No throttle ESC

Hi,

I'm having a problem getting any response from my ESC and Motor through my throttle channel. The Motor and ESC definitely work because they're brand new and working fine through the Aileron port in the receiver. Also, the throttle port works with a servo but not the ESC. I have tried calibrating the ESC to the throttle but get no response at all. Any ideas world be great. Thanks

Equipment:
Transmitter: Spektrum Dx4e
Receiver: Spektrum AR400
ESC: AeroStar 30A Brushless ESC 5.0V 2A BEC, 2-4s LiPo
Motor: Trunigy Aerodrive D2826/10 1400KV
Battery: Turnigy 2.2 LiPo (2200 mAh)

Last edited by tsargeaunt; 02-23-2018 at 10:49 AM.
tsargeaunt is offline  
Reply With Quote
Old 02-23-2018, 11:12 AM
  #2  
WMF Flyer
 
Join Date: Nov 2015
Location: Daventry, UK
Posts: 19
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I'm not familiar with the DX4e (I have Dx7,8 and 9). On the presumption that all other controls move the appropriate surfaces and it is just the throttle that is not responding then the first thought that crosses my mind is to move the throttle trim to the minimum position. From your description it just sounds as though the ESC isn't arming as it isn't seeing a low enough signal. Hope this helps and solves your problem.
Other possibilities: Try rebinding ensuring your throttle stick is at minimum. Try powering up the plane with the throttle stick in highest position then lower to bottom (ensure you either remove prop first or firmly secure plane and are clear of prop while doing so). Are you sure your throttle channel isn't reversed (the last suggestion should help identify if this is the case)?

Last edited by WMF Flyer; 02-23-2018 at 11:45 AM. Reason: further thoughts
WMF Flyer is offline  
Reply With Quote
Old 02-23-2018, 12:42 PM
  #3  
pilotpete2
 
pilotpete2's Avatar
 
Join Date: Oct 2002
Location: Lyndonville, VT
Posts: 3,295
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I second the motion to make sure that your throttle channel servo reversing is not set to reverse.
It should be normal usually when using and ESC.
It sounds like you've done some good basic troubleshooting there.
Good luck!
Pete
pilotpete2 is offline  
Reply With Quote
Old 02-26-2018, 08:38 AM
  #4  
AndyKunz
 
Join Date: Jun 2005
Location: White Heath, IL
Posts: 2,756
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Adjust your throttle trim all the way down. This is necessary for arming with some ESCs.

Andy
AndyKunz is offline  
Reply With Quote
Old 02-26-2018, 01:26 PM
  #5  
tsargeaunt
Junior Member
Thread Starter
 
Join Date: Feb 2018
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks for the responses and suggestions. I've tried adjusting the throttle trim all the way down and I've tried reversing the throttle channel with no success. Since my last post my receiver has been blacking out - it is unresponsive and the orange light flickers and goes out whilst on and connected to the transmitter. I checked the battery and the position and set up of the antennae and found that one of the antennae is slightly damaged. I've ordered a new one and hopefully the ESC will work with the new receiver.
tsargeaunt is offline  
Reply With Quote
Old 02-26-2018, 01:38 PM
  #6  
AndyKunz
 
Join Date: Jun 2005
Location: White Heath, IL
Posts: 2,756
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Test the ESC, motor, batteries with a different setup.

If that works, then I suggest you box up the receiver and transmitter and let Service take a look.

Andy
AndyKunz is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service