JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

rx issue

Reply

Old 04-29-2004, 12:59 PM
  #1  
JohnVH
Thread Starter
My Feedback: (38)
 
JohnVH's Avatar
 
Join Date: Dec 2001
Location: Ferndale, WA
Posts: 16,084
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default rx issue

Denny,
I have a 945rx that is brand new, I bought it a year ago and am finally getting around to using it. Anyway, its in a model that I need all 10 channels, and I cant get a range check at all. When I take the antenna off my 10x and start walking I get 10' max before going into hold. With antenna in and all the way down, 20', full antenna, 50' tops. I changed crystals in the rx and tx, and even tried a different channel with no luck..

So today, I had a spare 649 laying here, and I put it in, now I can get over 50' with the antenna off, dont know full range, but it was 10000 times better. SO, since the RX was so old what do you think I should do with it, what can be bad in it? Will JR take care of it.

Thanks
John
JohnVH is offline  
Reply With Quote
Old 04-30-2004, 08:57 AM
  #2  
dsnyder
 
dsnyder's Avatar
 
Join Date: Jun 2002
Location: Champaign, IL
Posts: 9,365
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: rx issue

It is difficult to speculate on what may be wrong with the receiver, perhaps it is a damaged crystal filter, but it does sound like it needs to come in for a check up. Outside of being sure to use the dual conversion crystals (red crystal case) for the 945, I don't have any other suggestions. JR equipment in the US carries a 3 year warranty. If you have a copy of the sales receipt, include that with the receiver. If you don't have a copy, include as much information as is possible as to where the receiver was purchased and approximately when.

http://horizon.hobbyshopnow.com/medi...rchecklist.pdf
dsnyder is offline  
Reply With Quote
Old 04-30-2004, 10:34 AM
  #3  
JohnVH
Thread Starter
My Feedback: (38)
 
JohnVH's Avatar
 
Join Date: Dec 2001
Location: Ferndale, WA
Posts: 16,084
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: rx issue

Ok, Thanks Danny
JohnVH is offline  
Reply With Quote
Old 04-30-2004, 01:59 PM
  #4  
JohnVH
Thread Starter
My Feedback: (38)
 
JohnVH's Avatar
 
Join Date: Dec 2001
Location: Ferndale, WA
Posts: 16,084
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: rx issue

Well, after thinking about your post for a bit Danny, I went and checked, yup, GREY crystal I happened to have a red case one, put it in, now Im good to go...

This is the first JR dual conversion RX I have used, so Im used to having singles laying around...

Thanks for mentioning that little detail!! Seems to have cured my problem![8D]
JohnVH is offline  
Reply With Quote
Old 04-30-2004, 04:04 PM
  #5  
dsnyder
 
dsnyder's Avatar
 
Join Date: Jun 2002
Location: Champaign, IL
Posts: 9,365
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: rx issue

That is excellent! Very good to hear! Please let us know if you have any further questions.
dsnyder is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service