KingTech Turbines International Barry is your host and will help you with all your Kingtech questions and concerns.

k45

Reply
Old 01-09-2018, 06:02 AM
  #26
lorenb
Thread Starter
 
Join Date: Nov 2016
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Red face

yes, but i dont know wich is the setting to adjust for that..
lorenb is online now  
Reply With Quote
Old 01-09-2018, 06:26 AM
  #27
mauryr
 
Join Date: Dec 2010
Location: , ITALY
Posts: 430
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

RPM Fuel Ramp K
RPM 100% Starter
These are the 2 parameters that control RPM in the fuel ramp phase.
Looking at the online manual for the K-45 I see the 100% starter is very high, so I guess on this engine is never really reached (the starter turns off at 28k).
The fuel ramp rpm is set to 15k rpm in the manual, but looking at your video, on your engine it should be more like 20k.
You could try raising it from 15k to 17k and see if this additional bump is sufficient to get the RPM through this phase.
In the video the critical phase seems to end at 21k where the combustion alone seems sufficient to accelerate well.
mauryr is offline  
Reply With Quote
Old 01-11-2018, 01:07 PM
  #28
lorenb
Thread Starter
 
Join Date: Nov 2016
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

no luck with this, im done with this engine
lorenb is online now  
Reply With Quote
Old 01-11-2018, 07:10 PM
  #29
mauryr
 
Join Date: Dec 2010
Location: , ITALY
Posts: 430
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Quote:
Originally Posted by lorenb View Post
no luck with this, im done with this engine
Raising starter motor rpm didn't help? Weird.
Did you manage to get a hold of Barry or Dirk?
mauryr is offline  
Reply With Quote
Old 01-12-2018, 03:04 AM
  #30
lorenb
Thread Starter
 
Join Date: Nov 2016
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

yes, didnt help the only answer o got was from Dirk by email, he told me that maybe is a starter and clutch issue, i took it out and all seems to be good, i dont know.
lorenb is online now  
Reply With Quote
Old 01-12-2018, 03:09 AM
  #31
gunradd
 
gunradd's Avatar
 
Join Date: Aug 2008
Location: Springhill, FL
Posts: 2,688
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Did the engine come this way out of the box? Never ran? Has this engine ever been crashed or damaged? A miss aligned starter bendix can cause the starter to not disengage and drag the engine causing hotter starts.has the starter ever been replaced?
gunradd is online now  
Reply With Quote
Old 01-12-2018, 03:15 AM
  #32
lorenb
Thread Starter
 
Join Date: Nov 2016
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

the engine was working fine from day one, but then installed a FOD screen and in a few days i notice that the starter was having to much vibes so i took it out and find that the shaft bushing was gone. I contact the dealer here in Argentina and he send me another starter motor, (without the clutch), installed the new motor and all this came up, its hang during the fuel ramp... the dealer here the only k45 that sell was the mine, maybe the starter motor is from another model on kingtech turbine and not have the right rpm, for example, when i make the manual cooling, the rpm reach 13k..
lorenb is online now  
Reply With Quote
Old 01-12-2018, 10:32 AM
  #33
gunradd
 
gunradd's Avatar
 
Join Date: Aug 2008
Location: Springhill, FL
Posts: 2,688
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Quote:
Originally Posted by lorenb View Post
the engine was working fine from day one, but then installed a FOD screen and in a few days i notice that the starter was having to much vibes so i took it out and find that the shaft bushing was gone. I contact the dealer here in Argentina and he send me another starter motor, (without the clutch), installed the new motor and all this came up, its hang during the fuel ramp... the dealer here the only k45 that sell was the mine, maybe the starter motor is from another model on kingtech turbine and not have the right rpm, for example, when i make the manual cooling, the rpm reach 13k..

ok. So you have a starter or clutch issue.

no setting on the ECU will help with this. At this point my advice would be to send it to an authorized service center. That way you know it will be fixed right.

shipping wise not sure if Taiwan or Cali is best but both will be able to get it done quick and have you back flying.
gunradd is online now  
Reply With Quote
Old 01-13-2018, 10:03 PM
  #34
marquisvns
 
marquisvns's Avatar
 
Join Date: Oct 2005
Location: Pasadena, CA
Posts: 1,722
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hi Lorenzo, I was forwarded your video from KingTech and it looked ok, some sputtery high velocity yellow flame is perfectly fine. My apologies for missing out on this thread and your email.

Regards,
Barry
marquisvns is offline  
Reply With Quote
Old 01-14-2018, 06:27 AM
  #35
lorenb
Thread Starter
 
Join Date: Nov 2016
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

sorry but i think it is no ok, was starting fine and then destroyed the pipe from one day to another, is it a lot of flames and is evident there is a problem with starter clutch.
lorenb is online now  
Reply With Quote
Old 01-14-2018, 10:30 PM
  #36
marquisvns
 
marquisvns's Avatar
 
Join Date: Oct 2005
Location: Pasadena, CA
Posts: 1,722
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Please get in touch with your local dealer, otherwise, send it to us here in the US for a service.

Regards,
Barry
marquisvns is offline  
Reply With Quote
Old 01-15-2018, 03:04 AM
  #37
lorenb
Thread Starter
 
Join Date: Nov 2016
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

perfect, i had send you a pm Barry, Thank you.
lorenb is online now  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:16 AM.