KingTech Turbines International Barry is your host and will help you with all your Kingtech questions and concerns.

k45 g2 starter motor issue

Reply

Old 01-30-2019, 05:10 PM
  #1  
snatch-it
Thread Starter
 
Join Date: Nov 2009
Location: red rose country, UNITED KINGDOM
Posts: 170
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default k45 g2 starter motor issue

hi all,
I have a very low runtime k45 g2.
on the odd start up or cool down the starter motor gives up. when it happens on start up it momentary engages and stops. when turning the rotor by hand the Bendix releases and starts as normal again. when it happens on cool down it spins once and that's it.
I emailed factory and they said to check all connections. all are clean and positive. five starts later it happens again.
battery is fine and all other readings are all ok.
any ideas???

regards

nigel
snatch-it is offline  
Reply With Quote
Old 01-31-2019, 04:15 AM
  #2  
mauryr
 
Join Date: Dec 2010
Location: , ITALY
Posts: 464
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

What oil are you using?
mauryr is offline  
Reply With Quote
Old 01-31-2019, 04:50 AM
  #3  
snatch-it
Thread Starter
 
Join Date: Nov 2009
Location: red rose country, UNITED KINGDOM
Posts: 170
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Kingtechs own oil.
It isnt sticky bearings. The rotor turns freely.
It happens on cool down aswell. Again the rotor turns free.
snatch-it is offline  
Reply With Quote
Old 02-02-2019, 10:15 AM
  #4  
marquisvns
 
marquisvns's Avatar
 
Join Date: Oct 2005
Location: Pasadena, CA
Posts: 1,787
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hi Nigel, Could you send me a video of the problem? When you take the video, if you could make sure that the GSU screen is visible and that we could hear what the starter motor is trying to do..... Also, do you have access to another K45, perhaps borrow its ECU to see if there's something wrong with the one you have. I have a feeling that there maybe something wrong with the ECU, perhaps just go ahead and send it in either to Taiwan or US, address found on the back of the manual, and if you could include a description of the problem, we'll program a fresh one to get you back flying again.

Thanks,
Bary
marquisvns is offline  
Reply With Quote
Old 02-02-2019, 11:29 AM
  #5  
snatch-it
Thread Starter
 
Join Date: Nov 2009
Location: red rose country, UNITED KINGDOM
Posts: 170
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks bary

problem is it doesnt do it every time.
It can be one in ten runs. If that.
Other problem is i dont have access to another k45.

When it does it on start up the starter sort of makes a squeal sound.
Then cuts out.
On cool down it does one flawless pulse then no more.
I have had the gsu plugged in to force a starter test and everything reads normal. But on starter test there was a squeal from the starter and what seemed to be a faint whiff of smoke out the front cover near the green plug.
But. As i say its only every now and then it faults!!

Regards

nigel
snatch-it is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service