Kyosho Helicopters Discuss all Kyosho heli topics here.

concept 30 eliectrical problem

Reply
Old 08-22-2008, 07:50 PM
  #1
westey
Thread Starter
 
Join Date: Aug 2008
Location: , UNITED KINGDOM
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default concept 30 eliectrical problem

hi all ive got a concept 30 but ime having a problem with it.every time i turn the radio and heli on its ok but after 20 seconds all the servoes keep twitchin and goin wild. i was wondering if any one new why it was doin it
westey is offline  
Reply With Quote
Old 08-23-2008, 03:39 AM
  #2
Kevinator9
 
Kevinator9's Avatar
 
Join Date: Jul 2006
Location: Auckland, NEW ZEALAND
Posts: 1,093
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: concept 30 eliectrical problem

could be something simple like radio inferferance, or flat batteries or something a bit more sinister like a bad radio or reciever or wiring but if it's not the interferance or batteries it might be a bit out of my league.
Kevinator9 is offline  
Reply With Quote
Old 08-23-2008, 09:47 AM
  #3
westey
Thread Starter
 
Join Date: Aug 2008
Location: , UNITED KINGDOM
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: concept 30 eliectrical problem

i have sorted out the problem thanks for your reply
westey is offline  
Reply With Quote
Old 08-25-2008, 12:14 AM
  #4
Kevinator9
 
Kevinator9's Avatar
 
Join Date: Jul 2006
Location: Auckland, NEW ZEALAND
Posts: 1,093
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: concept 30 eliectrical problem

What was the problem if you don't mind me asking?
Kevinator9 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:08 PM.