Losi Monster Trucks Discuss all Losi Monster Trucks (i.e. LST) in this forum. Optionally you may discuss this and all other MT's in our general MT forum.

My muggy!

Reply
Old 09-29-2011, 08:20 PM
  #1
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default My muggy!

If your reading this, then i traded!

What i got
TIRES:
integy rims with unkown tires
pretty mucgh brand new dirt bones on dish rims
traxxas revo rims
and some others i forgot

BODIES
4 bodies
t max, revo lst and some other one..
Engines
brand new axial .28rr
used lrp .28
MUGGY!!!AAAAAHHHHHH
high torque steering servo, think he said specktrum..!?

and a few other odds and ends,





and beside the green machine


going to get er all cleaned up..
esavagenoobie is offline  
Reply With Quote
Old 09-29-2011, 08:21 PM
  #2
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

@ b4 Haha, yea it was locally.. he has 2 tracks close within a year, no sence having a muggy to drive up and down your driveway.. so we traded!



Did some work tonite, i call it progress, but in the reality of the car, I am just scratching the surface. Which happens to be extremely durty.

The disassembly continues..

on the list of things to buy/replace, front shock tower.




Im guessing zero maintenance was done on the truck. I think i see a bearing wayyy down there...


rusty dogbones anyone?


they are due for a nice wd40 bath!


Stipped to the bone! or chassis atleast..


Filthy, absolutely filthy...


BEFORE they went into the bath...



and after...


Im sooo confident in my cleaning skills i even placed them on my mothers fresh washed linens..







With all that taken care off!





I cant start on this!



:doh::doh:

I need to replace screws, a front bulk head new wing some body posts.. going to call the LHS tomorrow and see if they have any of it in.. Would like to get this guy running for saturday-sunday.. We shall see tho.. still a SH1t ton of cleaning/re assembly to do..
esavagenoobie is offline  
Reply With Quote
Old 09-29-2011, 09:39 PM
  #3
HerrSavage
 
Join Date: Sep 2005
Location: Irgendwo, GERMANY
Posts: 10,292
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Nice Mug.. Don't forget that the Mug shares quite a few parts with the LST2 and XXL.

Single-piece engine-mount and single-servo plate are nice upgrades.. Need a starterbox for the former though..
HerrSavage is offline  
Reply With Quote
Old 09-30-2011, 05:03 AM
  #4
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

yea upgrades will come.. i just wanna get it all up and running first..
esavagenoobie is offline  
Reply With Quote
Old 09-30-2011, 04:41 PM
  #5
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

mam oh man... This think just keeps surprising me..



i think thats the first in history ive seen?



Alll broken!





And its all done!


Tallied up the broken plastic + some shock shafts and new seals, going to be about 50 bucks + new screws here and there and oil... what weight should i run? Im thinking 40..
esavagenoobie is offline  
Reply With Quote
Old 10-03-2011, 06:29 PM
  #6
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Well, shes all cleaned up, and 90 % back together..! Just need to mount the motor, figure out how to mesh nitro gears! (help) and mount tank then get some oil for shocks (40w?)


A before....







after...


Much better


slammed..
esavagenoobie is offline  
Reply With Quote
Old 10-05-2011, 02:10 PM
  #7
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

I JUST finished cleaning it..


bad .28 bad!



pooor pull starter..


all beter!


a little clean up!


and its back together, and ready for tomorrow!
esavagenoobie is offline  
Reply With Quote
Old 10-05-2011, 08:59 PM
  #8
HerrSavage
 
Join Date: Sep 2005
Location: Irgendwo, GERMANY
Posts: 10,292
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

What is that ridiculous looking pipe?! [X(]
HerrSavage is offline  
Reply With Quote
Old 10-06-2011, 02:49 AM
  #9
Muskokarc
 
Muskokarc's Avatar
 
Join Date: Sep 2010
Location: Huntsville, ON, CANADA
Posts: 490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

I know how you feel about the tear down.  I going through the same thing with my LST I got used.  Must have cleaned off about 2lbs of dirt off it.  The broken parts have added up to.  hmm need to get some fresh picks for my thread..
Muskokarc is offline  
Reply With Quote
Old 10-06-2011, 03:50 PM
  #10
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

@Herr, its a trinity pipe haha... i think its for 1/10th scale motors... but its temporary.. don't think I'm going to keep this guy nitro for long..

@muskoka, I know how you feel bud! Its a pain in the arse working on another rc that isn't your own..
esavagenoobie is offline  
Reply With Quote
Old 10-09-2011, 07:41 PM
  #11
bigben3576
 
Join Date: Oct 2011
Location: Haysville, KS
Posts: 19
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

HELP!! my losi lst2 wont respond to my radio anymore. it worked fine untill i charged the batteries in the truck with a new charger. now nothing happens at all. i have a jr xs3 radio. im thinking its the battery in the truck. im thinking about getting the AA battery tray back in it. any suggestions?

bigben3576 is offline  
Reply With Quote
Old 10-10-2011, 08:23 AM
  #12
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Thanks for spaming my thread dude..
esavagenoobie is offline  
Reply With Quote
Old 10-10-2011, 12:12 PM
  #13
bigben3576
 
Join Date: Oct 2011
Location: Haysville, KS
Posts: 19
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!



sorry. i didnt know how to make a new thread,and i seen you had a truck like mine so i thought id ask.

bigben3576 is offline  
Reply With Quote
Old 12-22-2011, 11:03 AM
  #14
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Forgot to update this thread haha, well nitro is almost all gone, and the truck is waiting for the Rc-monster muggy mount.. It was a 2100kv losi motor and a MMM waiting for the mount. heres a custom battery mount i fabbed up..


No one eh?

Anywhoo, progress of today.














Thats pretty much it for today. Im going to work on one more strap, that will run lenght wise to keep it nice and study. Even with those too, it takes quiet a bit to push the pack around. I smoothed off every edge so no worries about that. I'm pretty happy with the results as i only had a drill press and dremal available to me, and it turned out well considering.
esavagenoobie is offline  
Reply With Quote
Old 12-22-2011, 12:45 PM
  #15
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

esavagenoobie is offline  
Reply With Quote
Old 12-22-2011, 04:26 PM
  #16
Maj_Overdrive
 
Maj_Overdrive's Avatar
 
Join Date: Dec 2007
Location: Long Island, NY
Posts: 1,554
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Nice looking tray. I"m just a little worried about the mounting "tab" up front, not much meat where it meets the rest of the tray. Are you using any other screws underneath the pack to secure the tray?
Maj_Overdrive is offline  
Reply With Quote
Old 12-22-2011, 07:31 PM
  #17
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Well the 4 counters sunk screw holes you see in picture 4 (first post) mount to a beefy plate which mounts into the original engine mounting location which uses an hefty screw with double nuts. The mounts secure haha..
esavagenoobie is offline  
Reply With Quote
Old 12-23-2011, 12:23 PM
  #18
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

More progress, custom esc mount is fabbed, not keen on the hight of esc, still lower then the shock towers and the body mounts so its alright guess, and I hate Using zipties to fasten everything together, but for know it'll do.






Might need to run some more wire leads, as there little short. Shouldn't be a problem splicing another 2 inches into them..
esavagenoobie is offline  
Reply With Quote
Old 12-23-2011, 10:50 PM
  #19
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Thinking about swapping the 2100kv motor in the truggy and putting the 1800kv in this bad boy..
esavagenoobie is offline  
Reply With Quote
Old 12-28-2011, 08:25 AM
  #20
jspeed
 
Join Date: Dec 2006
Location: Tampa, FL
Posts: 269
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Nice project, more pictures!
jspeed is offline  
Reply With Quote
Old 12-28-2011, 02:19 PM
  #21
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Will grab some more once my mount comes in.
esavagenoobie is offline  
Reply With Quote
Old 01-03-2012, 12:48 PM
  #22
SavageDad
 
Join Date: Apr 2011
Location: CovingtonWashington
Posts: 23
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!


Quote:
ORIGINAL: esavagenoobie

a little clean up!


and its back together, and ready for tomorrow!
i still see dirt on the tanklookin good, but where th motor all clean pics? i accidentally flew off course last week into a mudd hole, im pist! now i need to clean clean clean, LST is a b***h to get stripped.

SavageDad is offline  
Reply With Quote
Old 01-03-2012, 03:50 PM
  #23
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Haha, well the nitro stuff is all gone know so who cares if thats dirty.. And yea that double decked lst must be a pita to clean..
esavagenoobie is offline  
Reply With Quote
Old 01-30-2012, 11:49 AM
  #24
esavagenoobie
Thread Starter
 
Join Date: Feb 2007
Location: Toronto, ON, CANADA
Posts: 216
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

Well ran it today, put about 11 minutes on the lipo, it was in storage mode and didnt not have all the power. Conditions were soggy and cold, -4 but it was wet outside, slide around a lot but the taped badlands did well, they didnt balloon at all! Here are some pictures, deciding whether or not i should post the video of the run..



ugh, it was clean..






the camera,



how it got dirty, im not sure..
esavagenoobie is offline  
Reply With Quote
Old 01-30-2012, 12:43 PM
  #25
devious1
 
devious1's Avatar
 
Join Date: Sep 2004
Location: Manitowoc, WI
Posts: 252
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: My muggy!

You should post a vid of the run...
muggy is coming along nicely
devious1 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:31 AM.