Losi Monster Trucks Discuss all Losi Monster Trucks (i.e. LST) in this forum. Optionally you may discuss this and all other MT's in our general MT forum.

I need help please

Reply

Old 03-27-2019, 04:15 AM
  #1  
ben foster
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default I need help please

My losi lst xxl2 starts then dies....wont stay running...does anyone have any advice what this could be and is thee a fix...any help would be much appreciated
ben foster is offline  
Reply With Quote
Old 03-27-2019, 07:38 AM
  #2  
D3MON
 
Join Date: Jan 2019
Location: Western MT
Posts: 14
Default

i am pretty new when it comes to the gasser engine on these,mainly run nitro.
had you tried resetting the needles back to factory settings? i do recomend you to take note of where they are at now as well.
checked the idle gap as well?
dies even with slight throttle blips or when idling?
checked the plug?
may be a fuel system leak? i think these are pressurized just like the nitro models and air leaks play havoc on tuning and if bad enough, on running.
D3MON is offline  
Reply With Quote
Old 03-27-2019, 05:57 PM
  #3  
ShopTech
Junior Member
 
Join Date: Mar 2019
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Have you tried a new glow plug?
ShopTech is offline  
Reply With Quote
Old 03-28-2019, 04:24 AM
  #4  
1QwkSport2.5r
 
1QwkSport2.5r's Avatar
 
Join Date: Oct 2006
Location: Cottage Grove, MN
Posts: 9,698
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

We need to know what engine is in the truck, what fuel you’re using, what glow plug or spark plug, and what you’ve already tried. Based on the OP, it could be any number of things causing trouble.
1QwkSport2.5r is online now  
Reply With Quote
Old 04-07-2019, 12:07 AM
  #5  
ben foster
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default different problem now

Originally Posted by 1QwkSport2.5r View Post
We need to know what engine is in the truck, what fuel you’re using, what glow plug or spark plug, and what you’ve already tried. Based on the OP, it could be any number of things causing trouble.
hey bud, thank you for your reply awhile back...just got back on here for the first time since then....you seem to be pretty knowledgeable....so since my last post I found a crack in my fuel tank...fixed it and now the truck stays running...my problem now is I have a very high idle...it is a Losi lst xxl-2 2 stroke...im way past break in stage...dynamic .31 motor ...14:1 2 stroke gas...ive tried adjusting back to factory settings...still high idle...any advice you can give me..tires don't move at idler but very high idle
ben foster is offline  
Reply With Quote
Old 04-07-2019, 04:32 PM
  #6  
1QwkSport2.5r
 
1QwkSport2.5r's Avatar
 
Join Date: Oct 2006
Location: Cottage Grove, MN
Posts: 9,698
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Dump the .31 gas engine. They’re nothing but problems. Honestly - nobody has had luck with them.
1QwkSport2.5r is online now  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service