Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 20 of 20

  1. #1
    funman1's Avatar
    Join Date
    Feb 2008
    Location
    Citrus Heights, CA
    Posts
    88
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Can't belive this engine RUNS!?!?! W/ Pics

    Yes I know this is a savage engine in a Losi forum, but I don't own a savage anymore and thought you guys would like this.

    My friend gave me this engine to work on for him.
    So I was just going to seal the back plate, carb, and Head to help it out a bit,
    And then just give it a general tune up...

    I dropped the back plate on the engine and my jaw dropped!!!
    See the pics!!

    This thing ran just before these pics!!?!?!?!

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Ge96367.jpg 
Views:	1 
Size:	52.7 KB 
ID:	961990   Click image for larger version. 

Name:	Lg16932.jpg 
Views:	1 
Size:	75.8 KB 
ID:	961991   Click image for larger version. 

Name:	Lq37076.jpg 
Views:	1 
Size:	61.8 KB 
ID:	961992   Click image for larger version. 

Name:	Ev23560.jpg 
Views:	1 
Size:	42.3 KB 
ID:	961993   Click image for larger version. 

Name:	Rt33572.jpg 
Views:	2 
Size:	60.7 KB 
ID:	961994  

    Click image for larger version. 

Name:	Dj46967.jpg 
Views:	1 
Size:	97.4 KB 
ID:	961995   Click image for larger version. 

Name:	Oz99550.jpg 
Views:	1 
Size:	85.9 KB 
ID:	961996  
    LST 2 (Best truck yet!)
    Had a Savage .25 till it got stolen

  2. #2
    full maxx's Avatar
    Join Date
    Aug 2007
    Location
    Eden, NC
    Posts
    2,019
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    rust much???
    LST2, MLST2, Blade CX2, Cen Gen LE ... funny how all these are second generation

  3. #3

    Join Date
    Nov 2006
    Location
    cambridge, ON, CANADA
    Posts
    94
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    hmmmm, Somebody never heard of after run oil.

  4. #4

    Join Date
    Feb 2008
    Location
    Belle Vernon, PA
    Posts
    392
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    LOL, looks like he used it to grill burgers on!

  5. #5

    Join Date
    Nov 2006
    Location
    cambridge, ON, CANADA
    Posts
    94
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    lol i'll take mine extra crispy with a side of rust.

  6. #6
    nitronut911's Avatar
    Join Date
    Feb 2008
    Location
    Greenville, WI
    Posts
    110
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    ahhh, hpi was never really known for engines anywayz. lol
    When in doubt... Go all Out!!

  7. #7
    iexion's Avatar
    Join Date
    Aug 2006
    Location
    Nowheresville, S.Dakota >_>, SD
    Posts
    1,778
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    The cost to save that engine might be worth just buying a new one. BUT if its dead set to restore that one. You can either 1: soak it in Transmission fluid ( i know this works for sure, just takes forever ) 2. My LHS owner said radiator fluid works really good (never tried it) 3. A new piston/sleeve, crank shaft head button and glow plug would be needed along with the back plate parts... But IMO i would try soaking it in radiator fluid then get out the drimmel and see what you can salvage

    But yeah, looks like its been sittin there for awhile and didnt use any after run oil... or at least some WD frekkin 40 [&:]
    Call me what I am. I am Kolossus

  8. #8
    RCtruckRacer's Avatar
    Join Date
    Jun 2005
    Location
    Eugene, OR
    Posts
    3,647
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    I have to agree - soak the whole thing in something. I wouldn't even bother with a dremmel and polishing tool. I'd just clean it as best as possible and then run it till it dies.

    Amazing pics, for sure!
    Some people see the glass half full. Others see it half empty. I see a glass that\'s twice as big as it needs to be.
    My opinions are my own, and are not necessarily those of RCU

  9. #9

    Join Date
    Feb 2008
    Location
    Indian River, MI
    Posts
    215
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    Wow it ran? Amazing

  10. #10

    Join Date
    Nov 2006
    Location
    cambridge, ON, CANADA
    Posts
    94
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    yea these little nitro engine can take a beating, I finally took apart my old mach 26 after the engine swap and found a giant scratch all the way down the pistion sleeve and a big dent on the pistion, looked like the exhaust port kinda bent and the pistion hit it. No wonder it would only idle and then choke on its exhuast.

  11. #11
    funman1's Avatar
    Join Date
    Feb 2008
    Location
    Citrus Heights, CA
    Posts
    88
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    hahah yeah this thing is back together, as is but (Did some soaking, but not much)
    And with the engine sealed now it's running like a champ!!!

    I think my firend is just going to drive it till it dies!!
    LST 2 (Best truck yet!)
    Had a Savage .25 till it got stolen

  12. #12

    Join Date
    Jun 2008
    Location
    , CA
    Posts
    1
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    This is my engine!!! YA im running it till it dies!! hopefully i can get a half galllon out of it

  13. #13
    ThunderbirdJunkie's Avatar
    Join Date
    Jul 2004
    Location
    Norwood, OH
    Posts
    22,101
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    pfft. That engine is fine.

    I'd run it and not care about it. I'd TRY to kill it. Those Force engines are workhorses.

    I don't see why it's surprising that it ran though?
    \"Some people can mess up an anvil with a rubber hammer\" -46u
    If you don\'\'t allow yourself to fail, you\'\'ll never allow yourself to succeed-ThunderbirdJunkie

  14. #14

    Join Date
    Jan 2007
    Location
    Campbellsville, KY
    Posts
    214
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    With that crankshaft rod bent like that I am sure it doesn't run all that well you are losing true top dead center. At least it looks bent to me probably from forcing it over while hydro locked.

  15. #15

    Join Date
    Nov 2007
    Location
    hervey bay, AUSTRALIA
    Posts
    1,276
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    How is the crank rod bent ? l think you looking at it wrong.
    l have worse looking engines, but, they didnt run long.
    That engine has had no after run, probably run in very wet or moist conditions, and treated and driven like its stolen, GOOD TO SEE !

    Neeeeeeexxxxxxxxxxxxxxxxxt !

  16. #16

    Join Date
    Jan 2007
    Location
    Campbellsville, KY
    Posts
    214
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    Looks like its bent down and to the right just a little I guess I should have said the rod journal, the connecting rod and crankshaft mating point. Doesn't it look like that to you?

  17. #17
    funman1's Avatar
    Join Date
    Feb 2008
    Location
    Citrus Heights, CA
    Posts
    88
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    That's just the starter pin.
    It slides into half of the connecting rod.
    It's not bent, it's just almost falling out...
    Snowduster Nice to see you joined, now go to the HPI forums hahahah
    Welcome....
    LST 2 (Best truck yet!)
    Had a Savage .25 till it got stolen

  18. #18
    black mamba's Avatar
    Join Date
    Jul 2005
    Location
    Hickory Hills, IL
    Posts
    5,388
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    Those early Savage engines will run until they throw the rod.
    Once you go BL and lipo, you will forget about nitro.

  19. #19

    Join Date
    Feb 2007
    Location
    carrington, ND
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    i love to see a motor looking like that and running fine ive seen them worse and still kickin

  20. #20

    Join Date
    Jun 2007
    Location
    Newaygo, MI
    Posts
    58
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Can't belive this engine RUNS!?!?! W/ Pics

    Not bad. I have a M26 sitting here with 2.5 tanks in it before it took out the rod and piston. I think I'd rather have a motor that looked like that and ran rather than this pile that broke and looks new.
    Team Losi LST w/ LRP .28
    WHH Manta Ray
    ParkZone Brushless J3 Cub
    F-27C Stryker


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:17 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.