Losi Monster Trucks Discuss all Losi Monster Trucks (i.e. LST) in this forum. Optionally you may discuss this and all other MT's in our general MT forum.

Can't belive this engine RUNS!?!?! W/ Pics

Reply
Old 06-02-2008, 12:59 AM
  #1
funman1
Thread Starter
 
funman1's Avatar
 
Join Date: Feb 2008
Location: Citrus Heights, CA
Posts: 88
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Can't belive this engine RUNS!?!?! W/ Pics

Yes I know this is a savage engine in a Losi forum, but I don't own a savage anymore and thought you guys would like this.

My friend gave me this engine to work on for him.
So I was just going to seal the back plate, carb, and Head to help it out a bit,
And then just give it a general tune up...

I dropped the back plate on the engine and my jaw dropped!!!
See the pics!!

This thing ran just before these pics!!?!?!?!

Attached Thumbnails
Click image for larger version

Name:	Ge96367.jpg
Views:	2
Size:	52.7 KB
ID:	961990   Click image for larger version

Name:	Lg16932.jpg
Views:	2
Size:	75.8 KB
ID:	961991   Click image for larger version

Name:	Lq37076.jpg
Views:	2
Size:	61.8 KB
ID:	961992   Click image for larger version

Name:	Ev23560.jpg
Views:	2
Size:	42.3 KB
ID:	961993   Click image for larger version

Name:	Rt33572.jpg
Views:	4
Size:	60.7 KB
ID:	961994  

Click image for larger version

Name:	Dj46967.jpg
Views:	2
Size:	97.4 KB
ID:	961995   Click image for larger version

Name:	Oz99550.jpg
Views:	2
Size:	85.9 KB
ID:	961996  
funman1 is offline  
Reply With Quote
Old 06-02-2008, 05:59 AM
  #2
full maxx
 
full maxx's Avatar
 
Join Date: Aug 2007
Location: Eden, NC
Posts: 2,019
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

rust much???
full maxx is offline  
Reply With Quote
Old 06-02-2008, 06:20 AM
  #3
BioRev
 
Join Date: Nov 2006
Location: cambridge, ON, CANADA
Posts: 94
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

hmmmm, Somebody never heard of after run oil.
BioRev is offline  
Reply With Quote
Old 06-02-2008, 07:34 AM
  #4
str8jailbird
 
Join Date: Feb 2008
Location: Belle Vernon, PA
Posts: 392
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

LOL, looks like he used it to grill burgers on!
str8jailbird is offline  
Reply With Quote
Old 06-02-2008, 04:37 PM
  #5
BioRev
 
Join Date: Nov 2006
Location: cambridge, ON, CANADA
Posts: 94
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

lol i'll take mine extra crispy with a side of rust.
BioRev is offline  
Reply With Quote
Old 06-02-2008, 05:43 PM
  #6
nitronut911
 
nitronut911's Avatar
 
Join Date: Feb 2008
Location: Greenville, WI
Posts: 110
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

ahhh, hpi was never really known for engines anywayz. lol
nitronut911 is offline  
Reply With Quote
Old 06-03-2008, 03:44 AM
  #7
iexion
 
iexion's Avatar
 
Join Date: Aug 2006
Location: Nowheresville, S.Dakota >_>, SD
Posts: 1,778
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

The cost to save that engine might be worth just buying a new one. BUT if its dead set to restore that one. You can either 1: soak it in Transmission fluid ( i know this works for sure, just takes forever ) 2. My LHS owner said radiator fluid works really good (never tried it) 3. A new piston/sleeve, crank shaft head button and glow plug would be needed along with the back plate parts... But IMO i would try soaking it in radiator fluid then get out the drimmel and see what you can salvage

But yeah, looks like its been sittin there for awhile and didnt use any after run oil... or at least some WD frekkin 40 [&:]
iexion is offline  
Reply With Quote
Old 06-03-2008, 09:48 AM
  #8
RCtruckRacer
 
RCtruckRacer's Avatar
 
Join Date: Jun 2005
Location: Eugene, OR
Posts: 3,647
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

I have to agree - soak the whole thing in something. I wouldn't even bother with a dremmel and polishing tool. I'd just clean it as best as possible and then run it till it dies.

Amazing pics, for sure!
RCtruckRacer is offline  
Reply With Quote
Old 06-03-2008, 11:08 AM
  #9
bjhe333
 
Join Date: Feb 2008
Location: Indian River, MI
Posts: 215
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

Wow it ran? Amazing
bjhe333 is offline  
Reply With Quote
Old 06-03-2008, 08:50 PM
  #10
BioRev
 
Join Date: Nov 2006
Location: cambridge, ON, CANADA
Posts: 94
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

yea these little nitro engine can take a beating, I finally took apart my old mach 26 after the engine swap and found a giant scratch all the way down the pistion sleeve and a big dent on the pistion, looked like the exhaust port kinda bent and the pistion hit it. No wonder it would only idle and then choke on its exhuast.
BioRev is offline  
Reply With Quote
Old 06-03-2008, 10:48 PM
  #11
funman1
Thread Starter
 
funman1's Avatar
 
Join Date: Feb 2008
Location: Citrus Heights, CA
Posts: 88
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

hahah yeah this thing is back together, as is but (Did some soaking, but not much)
And with the engine sealed now it's running like a champ!!!

I think my firend is just going to drive it till it dies!!
funman1 is offline  
Reply With Quote
Old 06-03-2008, 11:36 PM
  #12
snowduster99
 
Join Date: Jun 2008
Location: , CA
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

This is my engine!!! YA im running it till it dies!! hopefully i can get a half galllon out of it
snowduster99 is offline  
Reply With Quote
Old 06-04-2008, 02:10 AM
  #13
ThunderbirdJunkie
 
ThunderbirdJunkie's Avatar
 
Join Date: Jul 2004
Location: Norwood, OH
Posts: 22,101
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

pfft. That engine is fine.

I'd run it and not care about it. I'd TRY to kill it. Those Force engines are workhorses.

I don't see why it's surprising that it ran though?
ThunderbirdJunkie is offline  
Reply With Quote
Old 06-04-2008, 02:29 AM
  #14
freestylingford
 
Join Date: Jan 2007
Location: Campbellsville, KY
Posts: 214
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

With that crankshaft rod bent like that I am sure it doesn't run all that well you are losing true top dead center. At least it looks bent to me probably from forcing it over while hydro locked.
freestylingford is offline  
Reply With Quote
Old 06-04-2008, 06:01 AM
  #15
beer=food
 
Join Date: Nov 2007
Location: hervey bay, AUSTRALIA
Posts: 1,276
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

How is the crank rod bent ? l think you looking at it wrong.
l have worse looking engines, but, they didnt run long.
That engine has had no after run, probably run in very wet or moist conditions, and treated and driven like its stolen, GOOD TO SEE !

Neeeeeeexxxxxxxxxxxxxxxxxt !
beer=food is offline  
Reply With Quote
Old 06-04-2008, 05:47 PM
  #16
freestylingford
 
Join Date: Jan 2007
Location: Campbellsville, KY
Posts: 214
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

Looks like its bent down and to the right just a little I guess I should have said the rod journal, the connecting rod and crankshaft mating point. Doesn't it look like that to you?
freestylingford is offline  
Reply With Quote
Old 06-04-2008, 09:33 PM
  #17
funman1
Thread Starter
 
funman1's Avatar
 
Join Date: Feb 2008
Location: Citrus Heights, CA
Posts: 88
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

That's just the starter pin.
It slides into half of the connecting rod.
It's not bent, it's just almost falling out...
Snowduster Nice to see you joined, now go to the HPI forums hahahah
Welcome....
funman1 is offline  
Reply With Quote
Old 06-09-2008, 01:33 AM
  #18
black mamba
 
black mamba's Avatar
 
Join Date: Jul 2005
Location: Hickory Hills, IL
Posts: 5,388
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

Those early Savage engines will run until they throw the rod.
black mamba is offline  
Reply With Quote
Old 06-15-2008, 11:15 PM
  #19
brentmorl
 
Join Date: Feb 2007
Location: carrington, ND
Posts: 7
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

i love to see a motor looking like that and running fine ive seen them worse and still kickin
brentmorl is offline  
Reply With Quote
Old 06-18-2008, 06:21 PM
  #20
platinumjason
 
Join Date: Jun 2007
Location: Newaygo, MI
Posts: 58
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Can't belive this engine RUNS!?!?! W/ Pics

Not bad. I have a M26 sitting here with 2.5 tanks in it before it took out the rod and piston. I think I'd rather have a motor that looked like that and ran rather than this pile that broke and looks new.
platinumjason is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:57 AM.