Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

  1. #1

    Join Date
    Aug 2007
    Location
    Clearwater, FL
    Posts
    33
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    5000mah 11.1v lipo doesn't work out of the box :(

    So I got my 11.1v 5000mah lipo from maxamps today and was very excited to see it arrive. Upon charging it my triton rejected it several times saying "battery voltage too low". A few more tries to get it to charge and finally it took to it. The voltage of the pack reported to be 8.83 volts [:'(]. I think possibly one of the cells is dead. How do I check each cells voltage through the hyperion taps?

  2. #2

    Join Date
    Aug 2007
    Location
    Clearwater, FL
    Posts
    33
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 5000mah 11.1v lipo doesn't work out of the box :(

    I'm going to try running a couple more cycles through it and see if it stabilizes. For some reason the triton is only *****g out at 1.9 amps when it's set to 2.5?

  3. #3
    JAM MaxAmps's Avatar
    Join Date
    Jan 2007
    Location
    Nine Mile Falls, WA
    Posts
    556
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 5000mah 11.1v lipo doesn't work out of the box :(

    Stop what your doing and send the pack back. Give me your full name and order number. We'll get a new one out to you ASAP. E-mail the info to jason@maxamps.com . Better to be safe.

    Jason
    MaxAmps
    Jason
    MaxAmps Marketing Manager/Tech Support
    Jason@maxamps.com
    www.maxamps.com

  4. #4

    Join Date
    Aug 2007
    Location
    Clearwater, FL
    Posts
    33
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 5000mah 11.1v lipo doesn't work out of the box :(

    Email sent. Thanks for the quick reply and great support!

  5. #5
    JAM MaxAmps's Avatar
    Join Date
    Jan 2007
    Location
    Nine Mile Falls, WA
    Posts
    556
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 5000mah 11.1v lipo doesn't work out of the box :(

    I talked with Clint, Gave him the order ID # and he will contact you. He'll have you send it back for replacement.

    If you have any further questions just let me know.


    And thank you..

    Jason
    MaxAmps
    Jason
    MaxAmps Marketing Manager/Tech Support
    Jason@maxamps.com
    www.maxamps.com


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:48 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.