MRC Charger Product Support (i.e. Super Brain, etc) Tim Sandor of MRC/Hirobo is your host. Ask all your MRC questions here!

superbrain 820 won't recognize battery.

Reply
Old 09-21-2012, 08:47 AM
  #1
TheLoren
Thread Starter
 
Join Date: Jun 2008
Location: Rancho Cordova, CA
Posts: 8
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default superbrain 820 won't recognize battery.

I'm new to electric RC cars and I was recently given a Tamiya Ford SVT f-150 TL-01 shaft drive 4wd. I didn't get it new, but it looks to have been used very little. along with the truck I was given a MRC 820 SuperBrain AC/DC delta peak quick charger, and two super duty plus team Orion 3000mAh Ni-MH batteries.
I'm sure the batteries are completely dead because it looks like it has been sitting for years unused.

But when I plug the battery into the charger the light just blinks. and according the manual I found online it says that it should only blink if no battery is attached. I even let it sit on the charger for a couple hours to see if that would help. but neither battery will do anything. what should I do? I don't want to go buy new batteries and chargers if I can get the ones I got to work.
TheLoren is offline  
Reply With Quote
Old 09-21-2012, 01:18 PM
  #2
guver
 
Join Date: Mar 2003
Location: LaGrange, OH
Posts: 14,857
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: superbrain 820 won't recognize battery.

Since the battery has been setting a long time it should be charged with a dumb old wall charger for the first time. After that the 820 will probably work ok with it.
guver is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:30 AM.