Multi Rotor Helicopters Discuss Multi rotor RC Helicopter's here!

The Hubsan X4

Reply
Old 09-30-2012, 08:15 AM
  #1
cndianzhe
Thread Starter
 
Join Date: Apr 2006
Location: Shenzhen, CHINA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default The Hubsan X4


[youtube][/youtube]
http://www.youtube.com/watch?v=VngmW1RXZa8


cndianzhe is offline  
Reply With Quote
Old 10-09-2012, 02:20 PM
  #2
randall1959
 
randall1959's Avatar
 
Join Date: Aug 2004
Location: saint joseph, MO
Posts: 1,253
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Hubsan X4

I have the Hubsan X4, the WL Toys Beetle and the Udi RC U816 and the little Hubsan X4 is BY FAR my favorite. Here are some videos. This one compares the three in similar flights.
[youtube]http://www.youtube.com/watch?v=S0wejTeenDY[/youtube]
Here is the Hubsan X4 indoors.
[youtube]http://www.youtube.com/watch?v=7I5YjrDLrwo[/youtube]
Here is my first good outdoor flight. I was having trouble getting it to flip but found out you need to up the rates to 100%
[youtube]http://www.youtube.com/watch?v=-722hmTeAOc[/youtube]
And lastly, after getting the rates up to 100%
[youtube]http://www.youtube.com/watch?v=i1Phy8VLmP8[/youtube]
randall1959 is offline  
Reply With Quote
Old 11-17-2012, 11:14 AM
  #3
AKPhill
 
Join Date: Sep 2010
Location: Soldotna, AK
Posts: 49
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Hubsan X4

Does anyone know where to ge replacement parts for the hubsan x4 had a motor come apart
AKPhill is offline  
Reply With Quote
Old 02-14-2017, 06:24 PM
  #4
Larrysgolf
 
Join Date: Feb 2017
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I am new to quads. Got Hubsan x4 Pro for Christmas. First time I flew it, had a soft crash and now the control won't connect with quad. All lights come on and I can calibrate, but nothing beyond that. Propellers won't start. Can someone help me? Thanks!
Larrysgolf is offline  
Reply With Quote
Old 05-01-2017, 04:14 PM
  #5
Alleycat60
 
Alleycat60's Avatar
 
Join Date: Apr 2017
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Make sure your RTH switch is off. I have made that mistake a few times.

AL
Alleycat60 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:49 PM.