Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Nov 2006
    Location
    pulaski, VA
    Posts
    24
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    OS 120 Surpass FS Series

    Should this engine have to be rich at idle, seems very rich, and a little lean at full throttle?? The only way I can get a good idle is rich, alot of smoke. That also gives good transition to full throttle. After throttling down from full, chopping the throttle, it will idle lean for a few seconds, then go rich again, rpms are a little higher then drop a few when it richens up. It does not stop running.I am using a APC 14x10, 15% nitro,and OS (F)glow plug. When I take the battery off the glow plug, the rpm's drop a little and it seems to richen some at idle. I can only turn the mixture screw very little, the "sweet spot" is very small. I checked the fuel lines to the clunk and everything is good. It runs pretty good in the air. It started this last summer and does not seem to be getting worse. Just don't want it to go bad when maybe a simple fix is in order. Some say it does not hurt to use 2 stroke fuel in a four stroke, true?? I have used some 2 stroke in this engine, adjusted the needle valve a little and it ran great. The guy I got this engine from said he had it for a long time. Thinks it is the series 1. I can send it in if you think it needs some Pro TLC.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Om33420.jpg 
Views:	10 
Size:	73.8 KB 
ID:	1585951   Click image for larger version. 

Name:	Vm83542.jpg 
Views:	8 
Size:	60.7 KB 
ID:	1585952   Click image for larger version. 

Name:	Nt81735.jpg 
Views:	11 
Size:	55.0 KB 
ID:	1585953  

  2. #2
    Moderator
    Join Date
    Apr 2002
    Location
    Champaign, IL
    Posts
    18,197
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS 120 Surpass FS Series

    You may want to try a new glow plug, you may want to check the rocker arm/valve clearances. If the engine has had a lot of use before you got it, it may be wearing out, and you may need a new piston ring at the very least. If it's running well, you may just want to leave it alone.

    The first signs of an engine wearing-out its compression fit is an idle that's deteriorating because of the lowered compression.
    Bill Baxter, Manager Hobby Services/Futaba Service/North America
    3002 N. Apollo Dr. Ste. 1 Champaign, IL 61822 USA
    Service Phone: 217 398-0007
    Email: hobbyservices@hobbico.com

  3. #3

    Join Date
    Nov 2006
    Location
    pulaski, VA
    Posts
    24
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS 120 Surpass FS Series

    It has good compression, and I did put another glow plug in. The glow plug was not a four stroke plug and when I removed the hot shot the motor quit. The valve clearances are about .05 mm. Is this the series 1? Do you have a link for the piston ring?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 04:30 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.