Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1
    colosus's Avatar
    Join Date
    Jul 2005
    Location
    London, UNITED KINGDOM
    Posts
    91
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    OS SX 50 H-ring...little help please..

    Hi guys....
    Ok iam not a newbie to Helis or any RC models , its been in my blood for over 25 years....
    anyway i got this prob with the old SX 50 H-ring motor...its been in my ERGO 50 Schwietzer for about 7-8 years, i used to fly it every two-three weeks then life changed and started to fly less...i start this Heli every two or three months but normaly i would start it every month if i didnt forget ... but recently i cant seem to start her after leaving it for 4 months on the shelf with afterrun (not in carb), now for two weeks in a row i charged all batteries, tanked up and using my 180 Hobbyco starter with a large size 12v car battery ... tried to get her going...normaly with some turns she starts....but this time she blocks on what i think is the upstroke then turns better down stroke, i remove the plug and she turns with ease...as u know this is normal but the thing is ive burned out my 180 starter trying to get her going, my old 60 starter makes about two turns slowly, just not enough power there, em..i'am pulling my hair out whats left of it [&:] ...i looked at the carb setting and it seems to be set right with the switch on the transmitter, this switch sets the idle to a normal level to start her and also sliding the throttle slider on transmitter to give more throttle, ive not had to move any settings since she was first installed...but something is not right, the car battery went low on juice and starter cables hot.. this is not a heavly used motor, this Heli has never been upsidedown either, i fly her for the semi scale and the thrill, she is realy an old JRPropo beauty...check my photos and you will see her..

    Can some one help me out if they think they know what the prob is please.
    also i got no air-cleaner on the carb...some how either i had one and lost it or i never put one on...its escaped me

    cheers

  2. #2
    Moderator
    Join Date
    Apr 2002
    Location
    Champaign, IL
    Posts
    18,032
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS SX 50 H-ring...little help please..

    It sounds like your engine is getting hydraulic lock, That means oil, fuel, or such is getting into the cylinder and preventing the engine from turning over. If the engine turns over very smoothly when the glow plug is removed, then there you are. The cure is to remove the glow plug, turn the engine over with the starter for a bit before you attempt to start the engine. You may also want to make sure the muffler is drained of oil and there's no fuel in the tank or lines before you put the heli away for storage.


    Bill Baxter, Manager Hobby Services/Futaba Service/North America
    3002 N. Apollo Dr. Ste. 1 Champaign, IL 61822 USA
    Service Phone: 217 398-0007
    Email: hobbyservices@hobbico.com

  3. #3
    colosus's Avatar
    Join Date
    Jul 2005
    Location
    London, UNITED KINGDOM
    Posts
    91
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS SX 50 H-ring...little help please..

    Hi Bax and thanx for a response..

    Ok i have already tried turning the motor over without the glowplug for a good 30 or more secounds but once putting the plug back its turns then blocks, i also took the tank completely out and cleaned it, cleaned all fuel lines and then made a fresh tank up, i didnt yet look into the exhaust....when i say it blocks i mean it still turns but is very hard like its got so much compression then it makes a little puck sound as the piston strokes down then it turns easy....

    I will take the exhaust off on the weekend and clean it out.....if you think of anything else that it could be please send a message....

    i will let you know how it goes, once i try to start her again...em now with a burntout starter...hmm...

    Thanx


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:09 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.