Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Jun 2010
    Location
    Chesapeake, VA
    Posts
    126
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    OS 91 FS Pump not pulling fuel. Help?

    I have an OS FS91 w/pump that is not pulling fuel from the tank. I flew once today (temp approx 80) with no problems. The second time I tried to start the engine today if would not pull fuel from the tank. I checked out all the fuel connections and could not find anything wrong. I had the identical problem with a brand new pumped 91 on the same airplane which is on it's way to hobby services 2 weeks ago. I find it difficult to believe Iwould have the same symptons from 2 seperate engines. So as Isaid when I got home today I pulled the tank and checked all fuel connections. Nothing found wrong. Does anyone have any ideas? Are these pumped engines subject to vapor lock?

    Dave

  2. #2
    Moderator
    Join Date
    Apr 2002
    Location
    Champaign, IL
    Posts
    18,237
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS 91 FS Pump not pulling fuel. Help?

    If you remove the glow plug, disconnect the pump from the carburetor and then spin the engine with the starter, does fuel come out of the "out" port of the pump?  If so, the pump's working fine, and something else is wrong.  If your pump doesn't work, but did at one time, then it's gotten some kind of trash into it that's blocking an internal passage.  Trash getting into pumps is common.  You must be absolutely sure that you are filtering your fuel when it goes into the tank, and then filtering it before it goes into the pump.  Do not use muffler pressure, that will put trash into the tank.  Just vent the fuel tank from forward top and have it discharge out the bottom of the cowl/fuselage.


    Bill Baxter, Manager Hobby Services/Futaba Service/North America
    3002 N. Apollo Dr. Ste. 1 Champaign, IL 61822 USA
    Service Phone: 217 398-0007
    Email: hobbyservices@hobbico.com

  3. #3

    Join Date
    Jun 2010
    Location
    Chesapeake, VA
    Posts
    126
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS 91 FS Pump not pulling fuel. Help?

    Bax,

    I'll check it out and let you know. I doubt fuel is getting to the pump though. The line from the tank to the pump does not seem to be pulling fuel. I filter fuel when filling the tank and filter between the tank and carb. I would have normally blamed this problem on the pump. However due to another casualty (valve spring broke) I purchased a new pumped 91 to fly this plane. The same thing happened with the new one. Ran fine then quit. That one is on it's way to you now (should arrive Tues). I could not get a valve spring for the old one so I replaced the head. It ran fine for one flight then would not start up again. Because it happened on 2 of them I removed the fuel tank and completely checked out the plumbing. I could not find anything wrong. I have not had a chance to try and start the engine again since. I will be very interested in hearing what you folks find with the new one I sent back.

    Dave


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:18 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.