Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    Join Date
    Oct 2004
    Location
    brick, NJ
    Posts
    5
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    OS fs 48 Surpass running problem

    I have an old FS 48 which I bought new and used only a couple of times a long time ago. It has been in oiled storage since then. Recently I decided to try the engine and it started and ran fine on the ground. I mounted it in a Sig Rascal and flew it yesterday. In the air the engine speeds up, slows down, speeds up then eventually quits. Any ideas? I checked the tank and plumbing and all was ok. Engine is inverted and is running on 10% nitro with a 12x6 prop. I don't have a tach so could not measure RPM. Thanks for any help.

  2. #2

    Join Date
    Jun 2006
    Location
    Sun City Center, FL
    Posts
    1,270
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: OS fs 48 Surpass running problem

    Don't know what an FS is so guess thats Ts.Nobody knows how to spell????


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:11 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.