Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Nov 2008
    Location
    miami, FL
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    os 55 ax connecting rod problem

    hello guy :

    last saturday I was flying my jackal 55 with a os 55 ax and a bannggg spinner one way and prop the other way I have a emergency landing I check the engine and the connecting rod broke on lower secction I'm using cool power 15% fuel and 10x8 apc prop the muffler is a evolution JETT and the engine is only been used 5 times,is any way os will cover this by warranty and were to send the parts,I been reading a lot about this and is a lot of people with the same problem on the os 55 ax.

    any help is more thant welcome.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Ay74183.jpg 
Views:	13 
Size:	50.1 KB 
ID:	1606147  

  2. #2
    Moderator
    Join Date
    Apr 2002
    Location
    Champaign, IL
    Posts
    18,199
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: os 55 ax connecting rod problem

    Actually, there isn't a "lot of people" with the problem.  We just don't see seized rods with this engine.  I'd like to see the posts you mention.

    When a connecting rod lets go like that, it usually means that the rod's lower end seized to the crankshaft.  That happens when there's not enough lubrication.  The lower-end seizes and twists off as the crank tries to turn.

    We'd need to see the entire engine in order to make any kind of determinations.
    Bill Baxter, Manager Hobby Services/Futaba Service/North America
    3002 N. Apollo Dr. Ste. 1 Champaign, IL 61822 USA
    Service Phone: 217 398-0007
    Email: hobbyservices@hobbico.com

  3. #3

    Join Date
    Mar 2007
    Location
    Rockford, MI
    Posts
    154
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: os 55 ax connecting rod problem

    I use my 55 in an extreme flight chin yak. Have ran around 5 to 8 gallons through it. Noticed it making a little bit of a strange sound tonight. After inspection I found the rist pin seized to the rod. soaked in tranny fluid and got loose. Think it may have rusted or gummed. my bad. Gonna put back together and let eat.
    but whatever
    cheers

    FYI If you cannot get your rod off crank pin it,s because the rods seized forward on wrist pin!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:48 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.