O.S. Engines Support Ask Bill Baxter your questions about O.S. Engines.

OS 1.20 FS Poor Performance

Reply
Old 07-14-2013, 06:28 AM
  #1
steve_tb
Thread Starter
 
Join Date: Apr 2002
Location: Paradise, NL, CANADA
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default OS 1.20 FS Poor Performance

I have a 1.20 FS that is only putting out 8200-8400 rpm on a MA 15x8 prop. I have replaced the bearings, piston ring, gaskets and set the valves to spec. Compression improved but maximum rpm still is below what I would expect. My understanding is I should be getting 9,000+ but not even close. The engine is 10 years old but with the rebuild last year, it should be as good as new.

Am I missing something or is that as good as I can expect?

Thanks.
steve_tb is offline  
Reply With Quote
Old 07-15-2013, 06:30 AM
  #2
Bax
Moderator
 
Join Date: Apr 2002
Location: Monticello, IL
Posts: 19,479
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 1.20 FS Poor Performance

If your O.S. FS-120 is the old version with the two rocker covers, then the RPM level you're getting is about right. If you have an FS-120 Surpass, then it may be low on RPM. However, we've usually used a 15 x 8 APC propeller on our test stand, and see a little over 9,000 RPM. If the engine is really "right", and we have a good prop, we've seen the high 9,000's.
Bax is offline  
Reply With Quote
Old 07-17-2013, 08:02 PM
  #3
steve_tb
Thread Starter
 
Join Date: Apr 2002
Location: Paradise, NL, CANADA
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 1.20 FS Poor Performance

Thanks Bill. It is a Surpass so I'll try an APC 15x8 and see if I pick up a few hundred rpm.
steve_tb is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:16 AM.