Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

  1. #1

    Join Date
    Apr 2004
    Location
    NORTON, OH
    Posts
    40
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    radio problem for newbie

    Im working on a new plane and following the instruction. New batteries in transmitter. Battery charged for plane. connect battery to esc and attach switch lead to receiver. Switch on transmitter and then switch on receiver. The first time I did this it worked fine. Now it will not work at all. Help!

  2. #2

    Join Date
    Nov 2004
    Location
    Lakeland, FL
    Posts
    66
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: radio problem for newbie

    Have you check the connector from the battery to the receiver? Check another receiver or if your receiver is one that's need to bind to the transmitter have you check that?

    What transmitter and receiver are you talking about? Please give more info.

  3. #3

    Join Date
    Feb 2005
    Location
    , NY
    Posts
    128
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: radio problem for newbie

    Are you sure you are polarity Pos to pos, and not reversed? fonts are super small, and not in a wrong pin?

  4. #4

    Join Date
    Apr 2004
    Location
    NORTON, OH
    Posts
    40
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: radio problem for newbie

    OK radio is Futaba T4YF-2.4G.... ESC is SS-25 Brushless 5V/2A BEC....Battery is Electrifly BP 1250...1250mAh...11.1V 14Wh...receiver is Futaba R2004GF...I have tried to reverse the connection between the battery and switch...could I have ruined something. I bound the radio and receiver the first time as per instructions. If

  5. #5

    Join Date
    May 2002
    Location
    tain, , UNITED KINGDOM
    Posts
    25
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: radio problem for newbie

    I don't use Futaba, but suggest the following,
    Bind again, remove bind plug, switch off receiver, then be sure to turn off transmitter.

    Switch on transmitter, then switch on receiver. The thing to make sure is to turn off transmitter after
    binding, this is essential with Spectrum not sure about Futaba.

    Note the plugs and sockets on your gear is so designed that if you plug in the wrong way,
    ie not pos to pos, neg to neg and signal to signal as it should be, you won't damage anything but of course
    it won't work.
    Good luck, I know how frustrating it can be at first. john


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:29 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.