Q-40 Racing Discuss AMA 422 and any other variants of Quarter 40 racing

Anyone using Team Losi Voltage Regulators?

Reply

Old 03-24-2011, 07:32 AM
  #1  
plankdriver
Member
Thread Starter
 
Join Date: Jul 2006
Location: , OH
Posts: 38
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Anyone using Team Losi Voltage Regulators?

Anyone using Team Losi Voltage Regulators with 2 cell lipos SUCCESSFULLY?

Read something about the wires pulling/fallin off, and overheating. Don't know if true, false or fluke.

Any failures in pylon racers?

HAs anyone tried the Castle Creations BEC?
I got one laying around

Thanks

Chago
plankdriver is offline  
Reply With Quote
Old 03-24-2011, 07:46 AM
  #2  
garys
Senior Member
 
Join Date: Jan 2002
Location: Stansbury Park, UT
Posts: 937
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Anyone using Team Losi Voltage Regulators?

Hey Chago,
Yes, lots of people have been using the Losi regulators, and I'm not away of any issues. I'd say the Losi's are probably the most widely used in Q500/Q40, mostly because some of the first people to switch were Horizon supported racers and Losi's a Horizon product. I've been using the Associated regulators that appear to be pretty much identical without issue.
garys is offline  
Reply With Quote
Old 03-24-2011, 07:50 AM
  #3  
BarryReade
My Feedback: (1)
 
Join Date: Dec 2004
Location: Powder Springs, GA
Posts: 1,495
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Anyone using Team Losi Voltage Regulators?

I have 6-8 of them and been running them for the last three years with no issues.   It is the best considering weight, amp draw, and reliability.

You are the first to bring up issues that i have heard of.
BarryReade is offline  
Reply With Quote
Old 03-24-2011, 08:55 AM
  #4  
plankdriver
Member
Thread Starter
 
Join Date: Jul 2006
Location: , OH
Posts: 38
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Anyone using Team Losi Voltage Regulators?

Gary and Barry,

Thank you for the input. Just wanted to confirm reliability, which to me is #1 with racers, them weight then price.


Hope to start seeing y-all soon.

Chago



I've seen to lost my grrrove, Anyone seen it?
plankdriver is offline  
Reply With Quote
Old 03-24-2011, 09:51 AM
  #5  
bigtrev@xtra.co.nz
Senior Member
 
Join Date: Sep 2004
Location: christchurch, NEW ZEALAND
Posts: 320
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Anyone using Team Losi Voltage Regulators?

been using them for about 12 months- never had a problem...just be careful as to which way you install them though trevor h, nz
bigtrev@xtra.co.nz is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service