Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 8 of 8

  1. #1

    Join Date
    Jan 2005
    Location
    MentoneVictoria, AUSTRALIA
    Posts
    842
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Quadra 42 in Byron P51 -Ignition Help required

    Hi guys

    I'm finding my Q42 very hard to start and I see that Dick Bennet has a Engine Points Eliminator listed.

    Has anyone tried these out ?

    Also How do you get the magneto fly wheel off to get the points.?

    Any help would be great

    Alan

  2. #2
    Moderator w8ye's Avatar
    Join Date
    Dec 2001
    Location
    Shelby, OH
    Posts
    37,013
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    You may have a seal problem and not actually anything wrong with the ignition.

    If the rear seal is bad, fuel will not be pumped by the carb, or drawn into the crankcase or forced up into the combustion chamber very well. If you prime directly into the combustion chamber the engine will pop or maybe even go through three or four cycle but will never continuously run.

    Test your spark on a plug outside the combustion chamber first.
    Attended the CutFinger Institute of DirtNap University for years but never did graduate....
    Recipient, Mangledhand award August 2008
    Club Saito Member #7
    Original AMA #31261

  3. #3

    Join Date
    Jan 2005
    Location
    MentoneVictoria, AUSTRALIA
    Posts
    842
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    W8ye
    Thanks for the tip ....I've checked all seals and they seem fine but I will have another look.

    I assume the points have an advance/retard mechanism (similar to an auto ignition distributor), I think they may be getting stuck in the full advance position as the engine runs at over half to full throttle but stalls down low or runs very rough.

    The carb is new and the needles set at 1 1/2 turns as per the manual

    The engine has plenty of compression and a strong spark but want start until it get really warm/hot.

    Any idea on how to remove the magneto flywheel to get to the points to check if they are Ok ??

    I'll also try and find a full seal kit

    cheers


    Alan

  4. #4
    Moderator w8ye's Avatar
    Join Date
    Dec 2001
    Location
    Shelby, OH
    Posts
    37,013
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    The timing is fixed at 26-28 degrees. It doesn't move.

    To pull the flywheel, you will need a flywheel puller. They are available at the better auto parts stores.

    If you are getting a strong spark, there is nothing wrong with your points or coil.

    Does your carburetor pump fuel? You may have the crankcase pressure route to the carburetor blocked?
    Attended the CutFinger Institute of DirtNap University for years but never did graduate....
    Recipient, Mangledhand award August 2008
    Club Saito Member #7
    Original AMA #31261

  5. #5

    Join Date
    Apr 2003
    Location
    Enola, PA
    Posts
    46
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    Dear US41 user,

    In case your points are not good anymore.
    You can change the ignition to a normal US41 ignition setup with a new flywheel and a normal ignition module.

    All US41 paerts are in stock. Please contact USQ AERO, inc. under info@usqaero.com check out our home page www.usqaero.com

    Best of luck,
    Hanspeter Naef
    Customer Service U.S. Engines, Quadra and USQ
    USQ Aero, Inc.

    info@usqaero.com
    www.usqaero.com

  6. #6

    Join Date
    Jan 2005
    Location
    MentoneVictoria, AUSTRALIA
    Posts
    842
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    Hey Guys

    I just received the Dick Bennet transistor ignition module to retrofit to my Q42...........have anyone out there tried this setup ??

    cheers

    Alan

  7. #7

    Join Date
    May 2009
    Location
    wilmington, NC
    Posts
    6
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    please read my two posts 5-14-09 it will answer all your questions

  8. #8

    Join Date
    Jun 2010
    Location
    Lonoke, AR
    Posts
    2
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Quadra 42 in Byron P51 -Ignition Help required

    can you help....i have a byron p51 i am restoring and i can not get the engine to start...i prime it and it acts like it will start but then it dies...and solutions???


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:12 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.