Questions and Answers If you have general RC questions or answers discuss it here.

Eneloop charging

Reply

Old 08-01-2014, 09:14 AM
  #1  
CB36
Senior Member
Thread Starter
 
Join Date: Oct 2005
Location: Clifton Park, NY
Posts: 234
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Eneloop charging

Hi,
I just bought a 2000mA, 9.6v Eneloop pack for my Futaba 7C. I'm using an Accucycle Elite charger set at 0.80A peak charge. When the pack gets to the detection point, it is pretty warm. Not so much as I can't pick it up, but quite warm.

is this normal for this type of battery?

thanks!
CB36 is offline  
Reply With Quote
Old 08-01-2014, 04:03 PM
  #2  
Gray Beard
My Feedback: (-1)
 
Join Date: Apr 2003
Location: Hemderson, NV
Posts: 14,380
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Yes, I have noticed them being warm after charging but it usually happens when the pack was almost at a full charge. Been a while sense I have charged a pack so I don't recall where I have my chargers set at. The beauty of them is they don't self discharge so I don't even trickle charge them.
Gray Beard is offline  
Reply With Quote
Old 08-02-2014, 03:15 AM
  #3  
TomCrump
 
TomCrump's Avatar
 
Join Date: Apr 2003
Location: Traverse City, MI
Posts: 7,613
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I've been charging mine at .5 amp. They seem to like it.

Like Gene says, they hold their charge well. Like him, I don't trickle charge them, either.
TomCrump is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service