Questions and Answers If you have general RC questions or answers discuss it here.

Aileron servo MYSTERY on E-FLITE APPRENTICE

Reply
Old 10-21-2017, 06:30 PM
  #1
CharlieBwell1
Thread Starter
 
Join Date: Jul 2017
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Aileron servo MYSTERY on E-FLITE APPRENTICE

Bought a used E-FLITE S 15E Apprentice and Spektrum DX5E radio. Preflight revealed both aileron servos travel together. Either Flaps or Air-Brakes but no turning. Right servo (from behind) appears to be the Gray Original servo, but the left one has been replaced with one that has white+red+black wires (Futaba?) Both are hooked up to a single channel with a "Y" harness. One servo is mounted on its Left-Side, the other mounted on its Right-Side. Looks like this should work causing ailerons to work normally. Are Futaba servos wired to run "Left Handed"? Anyway I cannot find replacement servos anywhere. Does anyone understand ***, or where I can buy servos for the Apprentice? HELP. . . .
CharlieBwell1 is offline  
Reply With Quote
Old 10-23-2017, 04:24 AM
  #2
jetmech05
 
Join Date: Jul 2005
Location: Jacksonville, FL
Posts: 4,825
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Check this

Are both servos the same brand and model number? They need to be. Are they hooked up to a reversing Y? The servos need to be mounted so that they both face in board or both face outboard.
jetmech05 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:36 AM.