Questions and Answers If you have general RC questions or answers discuss it here.

Carbonfiber control links?

Reply

Old 02-04-2003, 11:21 AM
  #1  
Lean540
Senior Member
Thread Starter
 
Lean540's Avatar
 
Join Date: Feb 2003
Location: Calgary, AB, CANADA
Posts: 147
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Carbonfiber control links?

Has anyone used these?
Are they reliable?
I am afraid to try these, just worried to death the ends will pull out.
The application will be on a 27% Edge 540, this will be a high stress application (elevators)
Any thoughts?
Lean540
Lean540 is offline  
Reply With Quote
Old 02-04-2003, 01:44 PM
  #2  
krayzc-RCU
Senior Member
My Feedback: (31)
 
Join Date: Mar 2002
Location: Kannapolis, NC
Posts: 7,415
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Carbonfiber control links?

i have used these on various project and they hold together very well using exopy. its funny i had the same concerns when i 1st use them. you look at a plane doing a knife edge loop and realize the fin for the rudder is just glued on with a butt joint and that thing holds helps to really see the power of exopy and ca' glues.
krayzc-RCU is offline  
Reply With Quote
Old 02-04-2003, 03:33 PM
  #3  
gilcon
Senior Member
 
Join Date: Jan 2002
Location: Livermore, CA
Posts: 119
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Carbonfiber control links?

I'm using the Cental Hobbies ones with the titanium inserts on a 29% AW Edge. They work great. I also used black CA to hold them in - my personal pull tests showed it worked better than the JB weld that was recommended. I also slipped an aluminum ring over each end to keep them from splitting if there was a side load. I'd sure use them again and probably will on my 35% Carden Edge when I get it (kit anyway) next month. Good luck.

Hall
gilcon is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service