Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 9 of 9

  1. #1
    FahrtAutoRC's Avatar
    Join Date
    Aug 2010
    Location
    Akron, OH
    Posts
    2,587
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Steering issues, Losi 8ight buggy

    Not too long ago I picked up my first 1/8 buggy, a Tekno converted Losi 8ight. I am running a Savox SC-0251mg servo, rated 222 Oz./in., which is more than any amount I saw as a recommended bare minimum for steering torque. The problem is, once I set my trim, it will not stay centered. The servo horn is not slipping, no stripped teeth, and it does it even on very flat smooth surfaces. What could be causing this? Is it a fault in the servo, a simple servo saver adjustment, something worn or not working, what?
    Tekno Losi 8ight II Slash 4X4 II HPI Blitz II Associated B4.1 II Losi Mini-T II Custom frame AX10 II Axial G6

  2. #2

    Join Date
    Aug 2007
    Location
    Roseville, MI
    Posts
    1,070
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    it could be a servo,or a radio issue, maybe the receiver I've never really heard of this problem before. Wish I could help more....sorry.
    it wouldn't hurt to check your set up either maybe the camber is making the buggy pull???
    ((((((((MARSHALL!!!!)))))))

  3. #3
    FahrtAutoRC's Avatar
    Join Date
    Aug 2010
    Location
    Akron, OH
    Posts
    2,587
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    Meh, at this point I think I will just throw a higher end servo at it for starters. I went thru everything, linkage to ackermans to hubs, nothing is loose or worn, this buggy truly only had a half dozen runs on it before it was converted, and a few more after. The guy wasn't BS'in on it being a new ride! Anyways I will see if that works better. Thanks anyway!

    ORIGINAL: rccheech

    it could be a servo,or a radio issue, maybe the receiver I've never really heard of this problem before. Wish I could help more....sorry.
    it wouldn't hurt to check your set up either maybe the camber is making the buggy pull???
    Tekno Losi 8ight II Slash 4X4 II HPI Blitz II Associated B4.1 II Losi Mini-T II Custom frame AX10 II Axial G6

  4. #4

    Join Date
    Aug 2007
    Location
    Roseville, MI
    Posts
    1,070
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    Keep us posted. Would like to know if you get it sorted out.
    ((((((((MARSHALL!!!!)))))))

  5. #5
    JoePit's Avatar
    Join Date
    Jan 2012
    Location
    PeoriaAZ
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    I have a similar problem with my 8ight. When i turn it left it goes pretty much back to center. When I turn right it goes past center and causes the wheels to point left and obviously pull the car in that direction. After I get some speed it will straighten out. On the car stand is when I see exactly what it is doing. If I try to straighten with trim it will have the opposite effect. Wednesday my Hitec Steering horn will be here and we'll see if the new servo fixes my problem.

  6. #6
    FahrtAutoRC's Avatar
    Join Date
    Aug 2010
    Location
    Akron, OH
    Posts
    2,587
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    Let me know! This week I am too busy and stretched to thin to deal with my own, so hopefully you can find the problem for me!

    ORIGINAL: JoePit

    I have a similar problem with my 8ight. When i turn it left it goes pretty much back to center. When I turn right it goes past center and causes the wheels to point left and obviously pull the car in that direction. After I get some speed it will straighten out. On the car stand is when I see exactly what it is doing. If I try to straighten with trim it will have the opposite effect. Wednesday my Hitec Steering horn will be here and we'll see if the new servo fixes my problem.
    Tekno Losi 8ight II Slash 4X4 II HPI Blitz II Associated B4.1 II Losi Mini-T II Custom frame AX10 II Axial G6

  7. #7
    JoePit's Avatar
    Join Date
    Jan 2012
    Location
    PeoriaAZ
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    So I rigged my Hitec 7955 in today before the horn gets here tomorrow. I used the blue aluminum horn that comes with the servo to get me going today cause the anticipation was killing me. Had to bore the last hole on the horn out, but it works great! Needless to say this thing now goes back to dead center, and it does it in a hurry.

    Here's a video of what it is doing now. 1 problem... No video of before when it would never go back to center after turning right. The speed of this thing is insane compared to the stocker. Imagine this thing has been just sitting in my toolbox for months.

    http://www.youtube.com/watch?v=qsH7HvpB5F8


  8. #8
    FahrtAutoRC's Avatar
    Join Date
    Aug 2010
    Location
    Akron, OH
    Posts
    2,587
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy

    So, servo it is? Weird, i've been running these cheaper savox's for a minute now and never had an issue until this buggy. Will try a new servo in due time then Thanks!
    Tekno Losi 8ight II Slash 4X4 II HPI Blitz II Associated B4.1 II Losi Mini-T II Custom frame AX10 II Axial G6

  9. #9

    Join Date
    Jan 2008
    Location
    Pompano beach, FL
    Posts
    302
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Steering issues, Losi 8ight buggy


    ORIGINAL: JoePit

    *I have a similar problem with my 8ight. When i turn it left it goes pretty much back to center. When I turn right it goes past center and causes the wheels to point left and obviously pull the car in that direction. After I get some speed it will straighten out. On the car stand is when I see exactly what it is doing. If I try to straighten with trim it will have the opposite effect. Wednesday my Hitec Steering horn will be here and we'll see if the new servo fixes my problem.
    I just bought an 8ight 2.0 RTR and I'm having the same issue with the steering. Only centers one direction. Also, the throttle servo blows. So it's safe to assume that when I purchase the new servos, I should be set?

    Next question...Good servos for throttle/brake? I've heard about these savox lately, but have no experience with them. What are people typically running? No one wants to break the bank, but I need to have good servos...

    Thanks
    \"I seemed to have hit a speed bump..\"
    \"No, that was just his Revo!\"


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:42 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.