Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 16 of 16

  1. #1

    Join Date
    Mar 2010
    Location
    , ON, CANADA
    Posts
    2
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Buggy Help :( running terrible

    Hello All,

    New the site and forums. i may be blind but i had an issue and i looked around and didnt see any topic on this. sorry if this is in the wrong section, and sorry if its been talked about.
    i had an issue with my Nitro RC today
    she was having trouble starting at first, and when i had it going it just rev's super super high like i have full throttle, but the throttle trim is only set maybe a small notch. its not fully open and the throttle is barely pressed. then i took off all the trim and tried to drive around. i noticed that if i try to give it gas, it has a loud whine and it sounds like its at top speed, but the thing is barely moving. maybe im an idiot but i have been thinking about it and im not sure what it iwas. this is my 3rd time running the car . it didnt do this the first two times either. i've checked trim, high and low, and idle control and they are all set at stock. im not sure what grade fuel i am using because i can't find a percentage on the bottle anywhere. i recently got it from the internet this year, it is a kit car, pre assembled. its an exceed madfire .28 4 wheel drive. the only other thing that i do not think is an issue, maybe someone can confirm, but the front right axle broke, when i was not familiar with the car i was ripping it in a field and cranked the wheel, oh man did it roll. it broke the wheel stop and that was it. then the second time the axle went cause the wheel stop didnt prevent it from over pivoting. my bad lol. so its really a 3 wheel drive car. but i dont not see that being an issue with the engine performance. it s hould be easier not having to function all four wheels. and the front driveshaft should spin and the same rate with or without the axle.

    hopefully someone can help me out.

    Thank you so much.

    Justin M

  2. #2

    Join Date
    May 2007
    Location
    Anchorage, AK
    Posts
    1,653
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    If the engine is reving up and the car barely moves, then the clutch probably isn't engaging...

  3. #3
    1ne8ighty2wo's Avatar
    Join Date
    Nov 2009
    Location
    Ventura, CA
    Posts
    364
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    ORIGINAL: BigPappaTeddy

    its an exceed madfire...
    Well there's your problem . Exceeds simply aren't high quality cars so they are bound to break from normal wear and tear, and really break from collisions/user fault issues.

    As for your problem, it sounds like the clutch is shot. Take off the engine, take off the clutch bell, and see what it looks like. If it's one with a wrap around spring, that is probably snapped. Your LHS (local hobby shop) might have one that will fit it, but probably not seeing as Exceed isn't a big brand name.
    Did it start barely moving in mid run or was it working fine then the next time you fired it it stopped going?

    Also, did you break it in properly? Probably doesn't have to do with your problem, but it can cause serious problems later. I ask because you said this is the third time running it and you said you were ripping around in a field before. I didn't know if you meant third tank or third outing or what

  4. #4

    Join Date
    Dec 2008
    Location
    hayward, CA
    Posts
    66
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    thats your problem all your drive is lost whith your broken dog bone,fix it and it will hook up again.

  5. #5
    SyCo_VeNoM's Avatar
    Join Date
    Jul 2007
    Location
    chicago, IL
    Posts
    12,030
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible


    ORIGINAL: gearjammen

    thats your problem all your drive is lost whith your broken dog bone,fix it and it will hook up again.
    correct the diffs transfer power to the wheels that has least resistance (seeing they have the least traction) which in this case is the place where there is no dogbone.
    With great speed comes greater repair bills.
    Click on My models to see some of what I own. Eventually will add the rest

  6. #6

    Join Date
    May 2009
    Location
    antwerpen, BELGIUM
    Posts
    1,968
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    yep. fix you drive shaft and your problem will be solved.

  7. #7

    Join Date
    Sep 2009
    Location
    friendswood , TX
    Posts
    127
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    im an owner of this exact same car only a .21 r spec version by nanda , same car smaller engine with all the bells and whistles of the 28 version ,anyway its sounds to me as if you got three things going on it a little screwy , first turn the car on , and test to make sure the throttle servo is ok when you applie thottle, dose the arm move full open with a grinding noise or dose it it even move much at all if it has either of these issues wrong with it , the servo is toast , not bashing exceed but the throttle servos are weak as all but for 200 to 240 its not to much a loss , anyway also fix the front shaft and stopper in general that will ammount to alot of issues there since all the power is going to that wheel or uhh outdrive ,also when i first took mine out to the track after breaking it in i to had a clutch issue , very easy to fix , remove engine , 4 bolts on underside unhook throttle a fuel tube , making sure tank is empty of course and unscrewing pipe hanger bolt down and removing fuel tube off pipe and then remove the clutch bell with and allen wrench , not sure on size but.. you get the idea one you have removed the clutch bell , check the shoes if one is hanging free , it should be simple to fix remove that once shoe and use a flat head screwdriver to hold the spring of the clutch spring so you can pop it back on , give it a tiny tweak with your finger to see if it springs back and install all the parts and try again
    also exceed mad series are just fine , same quality as the big boys its the 10th scales that you gotta watch out for

  8. #8

    Join Date
    Sep 2009
    Location
    friendswood , TX
    Posts
    127
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    also the clutch on the madfire is a tradition 3 shoe race clutch with 1mm springs

  9. #9

    Join Date
    Mar 2010
    Location
    , ON, CANADA
    Posts
    2
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    Thank you everyone who helped in replies!

    Man, the dude at the hobby shop is not a fan of me haha. i went in asking for the part, but he doesnt stock exceed parts, because he doesnt sell them. he was kinda a dick, but then i was looking around and found the part with a different make, it was totally identical so i bought it. now all four wheels are in tact and functioning. i have yet to run it to see if that is the real issue but i would like to thank everyone for being so fast with responses. if that isn't the problem (the axle)then the next step is clutch, but im sure the axle is the problem. from what ive seen on forums maybe buying an exceed was a bad choice, but hey, beginner car and it was cheap . anyway ill be posting on here and reading a lot about these things, again thank you to everyone for the help .

    Justin M

  10. #10
    SyCo_VeNoM's Avatar
    Join Date
    Jul 2007
    Location
    chicago, IL
    Posts
    12,030
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    ORIGINAL: BigPappaTeddy

    Thank you everyone who helped in replies!

    Man, the dude at the hobby shop is not a fan of me haha. i went in asking for the part, but he doesnt stock exceed parts, because heΒ* doesnt sell them. he was kinda a dick, but then i was looking around and found the part with a different make, it was totally identical so i bought it. now all four wheels are in tact and functioning. i have yet to run it to see if that is the real issue but i would like to thank everyone for being so fast with responses. if that isn't the problem (the axle)Β*then the next step is clutch, but im sure the axle is the problem. from what ive seen on forums maybe buying an exceed was a bad choice, but hey, beginner car and it was cheap . anyway ill be posting on here and reading a lot about these things, again thank you to everyone for the help .

    Justin M
    I kinda can see why they get mad in ways. On some of my many LHS shop trips I saw a guy come in with some offshoot (might have been an exceed) and was asking for parts. They said they never even saw that model and told him he would have to go contact the manufacturer. The guy got pissy (for some reason), and started telling them they sold over priced crap... clerk said theres the door don't let it hit you in the ass on your way out
    Seen a few other arguments there from clueless people like ppl coming to buy their kids a RC and start questioning the prices when compared to a $30 tyco
    I usually see a fair bit seeing it takes me awhile cause I gotta go digging through all their bins for pieces to my RC's
    With great speed comes greater repair bills.
    Click on My models to see some of what I own. Eventually will add the rest

  11. #11
    The_Shark's Avatar
    Join Date
    Jun 2007
    Location
    Plainfield, IL
    Posts
    7,163
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible


    ORIGINAL: SyCo_VeNoM

    I kinda can see why they get mad in ways. On some of my many LHS shop trips I saw a guy come in with some offshoot (might have been an exceed) and was asking for parts. They said they never even saw that model and told him he would have to go contact the manufacturer. The guy got pissy (for some reason), and started telling them they sold over priced crap... clerk said theres the door don't let it hit you in the ass on your way out
    Seen a few other arguments there from clueless people like ppl coming to buy their kids a RC and start questioning the prices when compared to a $30 tyco
    I usually see a fair bit seeing it takes me awhile cause I gotta go digging through all their bins for pieces to my RC's

    hobby shop usually do sell over priced models compared to the net, they must make up for keeping the lights on, and again, you get what you pay for (usually)

    just a little off topic here.
    guy at the hobby shop got pissy with me because i didnt write down the part number- ive been shopping there for 10years, and most the time i have the P/N, and thats why im over-paying for parts, for service and convenience. that guy was being really sarcastic, but right before i blew up (and trust me, when i blow up, i never come back) one of the guys came to the rescue and found the part in 10seconds.

    at my lhs its either cheap off brands, traxxas or ultra-high end.

    by the way to the person with the exceed, if your clutch is bad after replacing the drive shaft, spend the extra few bucks for aluminum shoes.
    Signature
    (Max. 125 chars. 2 lines max)

  12. #12
    big_poppa49's Avatar
    Join Date
    Jan 2008
    Location
    Grover, NC
    Posts
    152
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    I would try and find another Hobby Shop in your area. Most hobby shops around here the clerks are nice and talk to you alot and really try to help you out and give you good info. Yes, sometimes they try to sell their parts and their brands, but its their business, and thats what they do, but if they're dicks than I wouldn't go back. I buy all my parts online, but if its something my LHS sells for about the same price, then I buy from there. That guy should not have been rude to you just b/c you have an off-brand model. You are new into it and that is what you choose to buy.

    As for me, my first nitro I bought was a Losi 8ight RTR 1.0 model buggy, USED!! Walked into my LHS and was asking a little about it and they gave me good info, and was rather friendly. They told me that I should not have got the RTR model and that I should have bought a NEW 2.0 model. But I got it cheap and its a start ya know. As of today I still have the buggy, still running the RTR motor, and have done a few upgrades (mostly part swapping from a 2.0 Race roller model) and I race it and usually advance to the main and hang in there pretty good. The guy at the hobby shop was right, I should have just got the 2.0 model, but I had fun tearing this thing down and putting in new parts, really got me familiar with the car. So in the end, I do NOT regret my purchase!!
    Losi 8ight Buggy

  13. #13
    The_Shark's Avatar
    Join Date
    Jun 2007
    Location
    Plainfield, IL
    Posts
    7,163
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible


    ORIGINAL: big_poppa49

    I should have just got the 2.0 model, but I had fun tearing this thing down and putting in new parts, really got me familiar with the car. So in the end, I do NOT regret my purchase!!
    ha, yeah same here, started out with a ravager roller for $125 but it came with big bore shocks, and jammin jp-2 pipe (alone cost $160 new) so i figured what the hell. well hundreds of dollars later its a MBX comp pro, with F/R pillow ball, jpx.21 metal gear servos, chassis improvements diffs.ect,ect.

    so sure i spent more money than if i bought a jammin x1x, but now im so familiar with the car and got it set up pretty nice, its not too bad, its like fixing up a old car- in the end its more expensive, but its nice and "yours".
    Signature
    (Max. 125 chars. 2 lines max)

  14. #14
    big_poppa49's Avatar
    Join Date
    Jan 2008
    Location
    Grover, NC
    Posts
    152
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    Shark is right. Along with what I said, when you tear the thing down replacing parts, you get to know right quick how the buggy operates and some problems you may encounter. Like my Losi 8ight buggy has now become pretty much a 2.0 race roller, with a couple extra upgrades.

    So now its my "own" custom buggy in a way.
    Losi 8ight Buggy

  15. #15

    Join Date
    Sep 2009
    Location
    Whitby, ON, CANADA
    Posts
    62
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    the guys at my LHS were the same way when i brought my exceed in for a replacement part, just as i was about to storm out i saw a tamiya mighty ballista, now usually id think for $245( not including taxes)  CAD it would be a rip off but suprisingly i bought it and because i payed in cash they gave me a discount. now im starting to think different about my hs

  16. #16

    Join Date
    Mar 2010
    Location
    Port Arthur, TX
    Posts
    30
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Buggy Help :( running terrible

    There is another problem that everyone overlooked. This may not be the problem but I have a backdraft 3.5 from redcat ; just trying it out I love my hyper 7, and the plastic spur gear stripped out in one place. When the car would corner or I would hit the break near it it would just whine and rev the engine. 
         I do believe it is his wish bone and possibly his clutch. Usually if you run it without a wishbone it will burn the clutch. I have done this a coule of times before during a race,  back in the day. 


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 09:42 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.