RC Car General Discussions This forum is for all general discussions related to radio control cars. Check forums below for more specific categories if applicable.

Redcat 1/5 Rampage XT Monster Truck question

Reply
Old 10-28-2011, 08:49 PM
  #1
lenny7118
Thread Starter
 
Join Date: Feb 2011
Location: New Brunswick, NJ
Posts: 15
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Redcat 1/5 Rampage XT Monster Truck question

Hello, Will the DDM Dominator Pipe fit on the Redcat Rampage XT?
lenny7118 is offline  
Reply With Quote
Old 10-28-2011, 10:21 PM
  #2
nitrosportsandrunner
 
nitrosportsandrunner's Avatar
 
Join Date: Aug 2007
Location: skowhegan, ME
Posts: 9,502
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat 1/5 Rampage XT Monster Truck question

see vid:

[youtube]http://www.youtube.com/watch?v=uR5OeXIXnOc[/youtube]
nitrosportsandrunner is offline  
Reply With Quote
Old 11-05-2011, 01:46 PM
  #3
QSR1
 
Join Date: Aug 2011
Location: Pleasant Hill, IA
Posts: 17
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat 1/5 Rampage XT Monster Truck question

I have electric EXP pro 1/10 Volcano

Hooked up Lipo 2 cell 3300mah 7.4V battery

Ran like hell for about 5 minutes, now I have nothing when I hook up any battery
QSR1 is offline  
Reply With Quote
Old 11-05-2011, 01:54 PM
  #4
nitrosportsandrunner
 
nitrosportsandrunner's Avatar
 
Join Date: Aug 2007
Location: skowhegan, ME
Posts: 9,502
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat 1/5 Rampage XT Monster Truck question


Quote:
ORIGINAL: QSR1

I have electric EXP pro 1/10 Volcano

Hooked up Lipo 2 cell 3300mah 7.4V battery

Ran like hell for about 5 minutes, now I have nothing when I hook up any battery
does it have the ezrun speed control....or the big blue novatech one?

whats the "C" rating of the battery?

on a 3300mah you should get 10-15 minutes of runtime before the low-voltage cuttoff kicks in and kills motor power.

do you still have steering?

its also possible the connectors fried. i use deans, or "T" plugs(same thing basically) i dont like the tamiya or banana 4.0 plugs.
nitrosportsandrunner is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:03 PM.