Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 7 of 7

  1. #1

    Join Date
    Oct 2008
    Location
    pefferlaw, ON, CANADA
    Posts
    1,536
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Mamba monster issue

    Hey guys, ok here goes. I have two mamba monster systems. One is in a savage flux hp, the other in an emaxx brushless edition. The emaxx is geared to have the same rollout gearing as the flux so the trucks are basically geared identically. Both truck are only run on 6s. Here's my problem.
    The emaxx has way less punch, top speed and kills batteries twice as fast. I have the castle link and while the emaxx has a later software as the blur only has one software available, the trucks are setup identical. Also the emaxx has a jump when your getting on the gas moderately, it starts to go and has a jump and then continues accelerating linearly.
    Thoughts?
    The difference in power between the two is a huge amount. ...I'm lost?
    oversteer scares passengers, understeer scares drivers!-savagex,-savagexl,-savageflux,-revo3.3,-tmaxx3.3,-losi aftershock ltd

  2. #2
    yakfish's Avatar
    Join Date
    Feb 2008
    Location
    Fairborn, OH
    Posts
    2,429
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Mamba monster issue

    check your drive train something is probably binding. try removing the pinion and see if the truck rolls freely.

  3. #3

    Join Date
    Oct 2008
    Location
    pefferlaw, ON, CANADA
    Posts
    1,536
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Mamba monster issue

    Yes truck rolls freely.
    oversteer scares passengers, understeer scares drivers!-savagex,-savagexl,-savageflux,-revo3.3,-tmaxx3.3,-losi aftershock ltd

  4. #4
    Haddi Taha's Avatar
    Join Date
    Feb 2010
    Location
    Sydney, AUSTRALIA
    Posts
    1,901
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Mamba monster issue

    bigger tires make the motor and esc work harder if that helps
    Thunder Tiger MT4 G3- Tamiya TA06 Pro

  5. #5
    yakfish's Avatar
    Join Date
    Feb 2008
    Location
    Fairborn, OH
    Posts
    2,429
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Mamba monster issue


    ORIGINAL: steed2

    Yes truck rolls freely.
    try swaping the motors from one truc to another. You might have bearings that need replaced in the motor that is currently in the Emaxx. If you swap that motor into the Savage you will know you have an issue with the motor. if you put the motor that is currently in the savage into the Emaxx and have the same problem you will know that you don't have a problem with the motor and since the truck rolls freely that leaves just the ESC as the weak link.

    or maybe the settings on the RX/TX are different between the two trucks?

    On a side note: I would expect the Emaxx to be slightly quicker (due to weight) even if the rollout is exactly the same. IIRC the Savage should be a bit heavier than the Emaxx.

  6. #6

    Join Date
    Aug 2007
    Location
    QLD, , AUSTRALIA
    Posts
    1,747
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Mamba monster issue


    ORIGINAL: steed2

    Hey guys, ok here goes. I have two mamba monster systems. One is in a savage flux hp, the other in an emaxx brushless edition. The emaxx is geared to have the same rollout gearing as the flux so the trucks are basically geared identically. Both truck are only run on 6s. Here's my problem.
    The emaxx has way less punch, top speed and kills batteries twice as fast. I have the castle link and while the emaxx has a later software as the blur only has one software available, the trucks are setup identical. Also the emaxx has a jump when your getting on the gas moderately, it starts to go and has a jump and then continues accelerating linearly.
    Thoughts?
    The difference in power between the two is a huge amount. ...I'm lost?
    I've heard of this problem happening with the latest software, I've also heard that using an earlier version solves the problem but I'm not sure which version.

  7. #7

    Join Date
    Oct 2008
    Location
    pefferlaw, ON, CANADA
    Posts
    1,536
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Mamba monster issue

    I am going to try the savage flux motor in the emaxx as the emaxx motor won't fit in the flux. Thanks for the replies and I will definitely try an earlier software Kenny and let you know.
    oversteer scares passengers, understeer scares drivers!-savagex,-savagexl,-savageflux,-revo3.3,-tmaxx3.3,-losi aftershock ltd


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:23 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.