RC Drag Racing For all you straight line enthusiasts. Discuss all aspects of rc drag racing here!

RJ Speed Major Problems

Reply

Old 01-25-2018, 10:07 PM
  #1  
Rc Drag Racer 98
Junior Member
Thread Starter
 
Join Date: Dec 2017
Location: Palmdale, CA
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RJ Speed Major Problems

I've been building and getting my setup right on my new 3 cell RJ Speed pro stock, and I'm having a lot of problems. I was out today, and was making hits in the street (that I prepped the first 10 feet of with sugar water), when I noticed that the car rolls forward EXTREMELY slow, for almost a foot, then the power kicks in. It's extremely annoying, because I would like to start racing, and that would make me lose every time. Another big problem is every time I make a pass, the car just starts falling apart. I lost 2 screws and a bracket (that holds the rear axle on), and I almost lost a 3rd screw. The last and BY FAR biggest problem is the spur and pinion gears. After 5 minutes out, I destroyed, I mean destroyed, my spur gear. I put another on, and almost ruined that one. Please help, I don't have the money to constantly fix this car.
Rc Drag Racer 98 is offline  
Reply With Quote
Old 02-04-2018, 04:52 PM
  #2  
tntpooof
 
tntpooof's Avatar
 
Join Date: Feb 2018
Location: Detroit Michigan
Posts: 89
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

what is your actual set motor .esc battery type and size.. also do u have plastic spur pinions sounds like its to tight a mesh did you use a folded piece of paper to set mesh.. thats 2 layers of paper..
tntpooof is offline  
Reply With Quote
Old 02-10-2018, 01:33 PM
  #3  
tntpooof
 
tntpooof's Avatar
 
Join Date: Feb 2018
Location: Detroit Michigan
Posts: 89
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

i drag race ith mine 2x a weeks sorry but its less than a 2 second drive to do the 132 feet then back to me with a 1200amp brushed esc and a 2 turn tops racing motor only thing i have blown was my tires on my 1st run when they hit the chassis on expansion.. i replaced them with 10 mm smaller tires.. i run close to 128mph in less than .05 seconds so how r u running 5 minutes this is a drag car not a basher..
tntpooof is offline  
Reply With Quote
Old 02-15-2018, 08:20 PM
  #4  
Rc Drag Racer 98
Junior Member
Thread Starter
 
Join Date: Dec 2017
Location: Palmdale, CA
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The reason I'm out for a little less than five minutes is because I'm still learning the car. However, I can't tune or learn how to drive it when it literally just falls apart. I was going to go do some legit testing tomorrow, and my damn spur gear fell off. Lost three screws... That time I made one quick hit and was out for like 25 seconds, and when I drove it back, the car slowed down, and three screws were gone.
Rc Drag Racer 98 is offline  
Reply With Quote
Old 02-15-2018, 08:22 PM
  #5  
Rc Drag Racer 98
Junior Member
Thread Starter
 
Join Date: Dec 2017
Location: Palmdale, CA
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

When I mean twentyfive seconds I don't mean the pass. The pass was less than 3 seconds at 1/2 to 3/4 throttle, and I had to pedal it. It's fast but just falls apart.
Rc Drag Racer 98 is offline  
Reply With Quote
Old 03-11-2018, 06:05 PM
  #6  
Rc Drag Racer 98
Junior Member
Thread Starter
 
Join Date: Dec 2017
Location: Palmdale, CA
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I think I'm going to run on 1s and 2s, 3s is too much. I'm going to buy a castle link, and get tunes for both batteries then just upload them according to the battery I'm running before each run.
Rc Drag Racer 98 is offline  
Reply With Quote
Old 03-14-2018, 09:56 PM
  #7  
if6were9
Junior Member
 
Join Date: Mar 2018
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hi Rc Drag Racer 98,
I don't want you to think I'm bashing your RJ Speed pro stock car because of what I say here! But,
that car was not made to handle 3s lipo (that's probably why you're destroying spur gears).
I raced several RJ Speed cars (pro stock and dragster) some years back and understand your frustration with it.
It's a handful with 2s lipo and a low turn motor. I'm a "no prep" parking lot racer so I raced with 1s and both cars were fast.
With a few "low dollar" modifications and a little work, the RJ Speed cars can be made pretty reliable without falling apart and
destroying things. I'd be glad to help, but have a few questions I need answers to so I can get an idea of what your working with...

1. Is the car stock out of the box?
2. What Castle speed control are you using?
3. What turn motor are you using? What brand is the motor?
4. Do you have a 2s lipo battery? If so, what brand battery and what's the mAH and C rating?

Here's a few pics of my old RJ Speed pro stock
(that's the way it looked when I sold it - the electronics and a few other things were different when I raced it)

LMK,
if6were9
Attached Thumbnails Click image for larger version

Name:	Right Side.JPG
Views:	100
Size:	2.29 MB
ID:	2259232   Click image for larger version

Name:	Chassis (left side).JPG
Views:	103
Size:	2.16 MB
ID:	2259233  
if6were9 is offline  
Reply With Quote
Old 09-23-2018, 03:08 PM
  #8  
Blkft1
 
Join Date: Dec 2007
Location: Mesquite, TX
Posts: 240
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

This thread is several months old but I'll post anyway. I plan on picking up the RJ 24" Dragster or a Pro Stick, hadn't decided yet. This will primarily be for some cheap parking lot runs and fun with friends. I plan on using some new closed endbell takeoff motors I have, a 15T and 20T, gearing is undecided as is a esc. I have some 2S 50C 1300mah Hyperion cells. These are small and light weight. Given the info above will these cells be fine?
Thanks!
Blkft1 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service