RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

ESC troubleshooting

Reply
Old 06-27-2011, 06:48 AM
  #1
NewRageRC
Thread Starter
 
Join Date: May 2011
Location: Palo, IA
Posts: 195
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default ESC troubleshooting

My neighbor crashed in to a mailbox and managed to break just the ESC in his Rustler. He's ordered a replacement so Ithought I'd try to troubleshoot the broken one and see if Ican't get it working. I pulled it apart and didn't find anything obviously broken, but I did find that the BEC is only outputting about 2.5v. It seems to me like this would most likely be a problem with a FET. I pulled out my multimeter but couldn't make any sense of the resistance I was seeing can anyone shed some light?Does my thinking make sense?
NewRageRC is offline  
Reply With Quote
Old 06-27-2011, 07:28 AM
  #2
NOVAMEGA
 
Join Date: Apr 2006
Location: Cincinnati, OH
Posts: 212
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ESC troubleshooting

A reflow on a esc board would be a headache ..... I wouldn't even know where to start . I'm not sayin try this cuz I don't have a clue , but if nothing looks broke on the board maybe try heating it up with a heatgun to try a poor mans reflow . I would only try that after you found out the FET specs ......I hope you get it working it sounds like a fun little mission .....
NOVAMEGA is offline  
Reply With Quote
Old 06-27-2011, 08:36 AM
  #3
NewRageRC
Thread Starter
 
Join Date: May 2011
Location: Palo, IA
Posts: 195
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ESC troubleshooting

I'll try the heat gun. If that doesn't work I'll probably just toss it. The BEC is on a seperate PCB soldered directly to the first with all the traces on the inside so you can't even make the circuit out.
NewRageRC is offline  
Reply With Quote
Old 11-06-2011, 12:08 PM
  #4
QSR1
 
Join Date: Aug 2011
Location: Pleasant Hill, IA
Posts: 17
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ESC troubleshooting

I have a Redcat Volcanp EXP pro electric

I hooked up a LiPo 2 cell 7.4 V to the truck and it ran awesome for about 5 minutes.

Now truck does nothing no lights on ESC, reciever nothing, even with stock battery.

I made sure the battery did not exceed truck limitations, what next?
QSR1 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:11 AM.