RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

Gen7 Pro leans to the left...?

Reply

Old 09-20-2019, 04:41 PM
  #1  
Sivart
Junior Member
Thread Starter
 
Join Date: Sep 2019
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Gen7 Pro leans to the left...?

Just picked up my first crawler, the Gen7 Pro. Out of the box I checked all the usual screws and bolts for tightness and that the various linkages were installed in the right spot. It all looked good. However, the whole truck leans to the left slightly even after cycling the suspension on all four corners several times. I havenít even powered it on yet in case I need to exchange it, but canít figure out whatís causing it. Any ideas? Has anyone else experienced this? Is it something that will work itself out after a few battery cycles?
Sivart is offline  
Reply With Quote
Old 09-21-2019, 03:59 AM
  #2  
rgburrill
 
rgburrill's Avatar
 
Join Date: Dec 2010
Location: Trumbull, CT
Posts: 2,163
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

No political discussions here.
rgburrill is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service