Notices
RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

16.8V New E-maxx

Old 05-24-2008, 06:57 PM
  #301  
Redvanmafia
Senior Member
 
Join Date: Mar 2008
Location: by the lake, ON, CANADA
Posts: 2,447
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

no dumas.s, what happend, happend DUMB First of all if its worth anything you dont get within 50ft of water,



MF2MM5700 - Were on the same page



.... carry on
Redvanmafia is offline  
Old 05-24-2008, 07:10 PM
  #302  
DriftingDragon
Senior Member
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

sorry bout that i had to blow all my cash on stuff i didnt want to get
DriftingDragon is offline  
Old 05-24-2008, 07:12 PM
  #303  
SavageX78
Senior Member
 
SavageX78's Avatar
 
Join Date: Feb 2007
Location: Laconia, NH
Posts: 1,157
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx


ORIGINAL: Redvanmafia

no dumas.s, what happend, happend DUMB First of all if its worth anything you dont get within 50ft of water,



MF2MM5700 - Were on the same page



.... carry on

Well I can tell ya 1 thing. If that was my emaxx with that much money in it I would not have been anywhere near water. But to each his own.


SavageX78 is offline  
Old 05-24-2008, 07:19 PM
  #304  
SavageX78
Senior Member
 
SavageX78's Avatar
 
Join Date: Feb 2007
Location: Laconia, NH
Posts: 1,157
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx


ORIGINAL: DriftingDragon

sorry bout that i had to blow all my cash on stuff i didnt want to get
Well if you didnt want it why did you have to get it.lol
SavageX78 is offline  
Old 05-24-2008, 08:07 PM
  #305  
DriftingDragon
Senior Member
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

school project
DriftingDragon is offline  
Old 05-24-2008, 08:08 PM
  #306  
SavageX78
Senior Member
 
SavageX78's Avatar
 
Join Date: Feb 2007
Location: Laconia, NH
Posts: 1,157
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx


ORIGINAL: DriftingDragon

school project

ohh.

Be cool. Stay in school! lol sorry im tired.
SavageX78 is offline  
Old 05-24-2008, 08:08 PM
  #307  
fisheydude
Senior Member
 
Join Date: Dec 2007
Location: bowling green, KY
Posts: 219
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx


ORIGINAL: mycarisaser

I lost all my electronics to water yesterday[sm=drowning.gif]. My 160Amp mgm esc , my bec, my futaba 2.4ghz reciever, and my lipos. I Jumped a sand pile wrong and landed in about 6 foot deep water. The lipos caught fire under water and melted the esc, the water killed the bec and I put a small hole in the radio box for the antenna and it let in alot of water, so good bye reciever. I was about 50+ yards out so it was in the water for a while. I was at the park in pants and a long sleeve shirt so I stripped down to my underwear and dove in (water was about 50*F and 60 outside[sm=what_smile.gif]) I got my truck after the lipos finally stopped exploiding and climbed the bulkhead out and walked about a 1/4 mile back to my car in my underwear soaking wet holding a melted emaxx. Not one of my better days( I got a few looks from people) So I guess its time to put in my castle monster order.

That sounds like a nightmare come true. I hope I never have a dream like that, I may die in my sleep!

Do any of you use nimh batts? All mine seem to swell and the end cell melts off the shrink wrap and the logo on the cell. I use maxamps 4700 batts and ib4600 batts. Both types seem to build up way too much heat... even with easy runs. May-be I should try different packs... any suggestions? Can't afford lipos and charger/balancer right now.[&o]
fisheydude is offline  
Old 05-24-2008, 08:18 PM
  #308  
SavageX78
Senior Member
 
SavageX78's Avatar
 
Join Date: Feb 2007
Location: Laconia, NH
Posts: 1,157
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

Well I had problems with my Duratrax 4200 cells getting way to hot but they were junk either way.
But yeah the motors seem to pull alot of amps which heats up the batts quick.
You could try letting it cool half way through a run. thats what i did id just let it sit for 5 minutes or more and the finish the packs off.


How hot are your motors getting?
SavageX78 is offline  
Old 05-24-2008, 08:35 PM
  #309  
DriftingDragon
Senior Member
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

would i be able to run 2 silvercans rather then the twin titans
DriftingDragon is offline  
Old 05-24-2008, 08:44 PM
  #310  
SavageX78
Senior Member
 
SavageX78's Avatar
 
Join Date: Feb 2007
Location: Laconia, NH
Posts: 1,157
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

ORIGINAL: DriftingDragon

would i be able to run 2 silvercans rather then the twin titans
I doubt it would last. But if you geared it rite and watched your temps it may work.

Why do you want to run the silver cans? Are your titans dead.

Edit: I dont think it would work because the motors wont be able to handle 14 volts or 16.8 what ever your running.
From what i understand each motor gets the 14-16.8 volts. Its not half to 1 and half to the other.
SavageX78 is offline  
Old 05-24-2008, 08:50 PM
  #311  
DriftingDragon
Senior Member
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

no i just dont like the 550s much
when it gets bout 1/2 charge it gets a severe drop in power like it will suddenly just slow down and you will hear the motors do their little low voltage song on half charge

do you think the stock pinions work (im only on 14.4v)
DriftingDragon is offline  
Old 05-24-2008, 09:38 PM
  #312  
fisheydude
Senior Member
 
Join Date: Dec 2007
Location: bowling green, KY
Posts: 219
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

mf2mm5700: The motors do get hot, too hot to keep a finger on them, but they seem to be holding up fine. The batts I am using charge up to 10.2 volts or so... Could that be the cause of the problems? I really trust these maxamps batts are good, may-be too good? [sm=confused.gif]
fisheydude is offline  
Old 05-24-2008, 10:05 PM
  #313  
DriftingDragon
Senior Member
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

im goin 4 it the worst that could happen is thee motors wont work rite not the esc
DriftingDragon is offline  
Old 05-24-2008, 10:47 PM
  #314  
DriftingDragon
Senior Member
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

ok guys im back
yes it cogged but it found "the groove"
it worked yes they got a bit toasty but it works fine
once the motors sync up it "FLIES" on 14.4v i was getting about 25-30mph
if your going to do it get heatsinks or heatsinks w/ fans

when i get the money i might try it with black cans or rz's but i think eventually ill find out from traxxas what gearing in need to put the titan 12t in
DriftingDragon is offline  
Old 05-25-2008, 08:14 AM
  #315  
mycarisaser
 
Join Date: Feb 2004
Location: Kitty Hawk, NC
Posts: 2,048
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx


ORIGINAL: Redvanmafia

Thats 600+ bucks gone, cause put his new 400 dollar e-maxx in the water, electricy and water dont mix, i dont want to hear anymore stupid storys, whos paying for all this?, if its you then great go for it spend all the money you want but if its daddys money, and you just go run that into the water, you wouldnt be my son anymore

hey man I live on a small island. There is water everywhere. Im not a kid I not rich either (30years old and make about $40,000 a year and I support a wife and 3 kids) It was accident I didnt know I was that close to the water. I was over 50 yards out from the truck(it got there quicker than I did). I had never ran in that area before and at a distance it looked just like a beach that slopped down to the water(no big deal) but it wasnt it was bulkheaded(no more sand) and I jumped the little sand hill twice before hitting it the wrong way. I didnt even know it had fell into the water. I tried to revese it b/c it was out of my sight and then I seen water flining up. So I tried to go straight and seen the same. I thought it was just stuck or something until I got up to it and seen that it was 3 1/3 feet down in to the water(salt water to boot[])

Man crap happens. I have these things to have fun with. I jump my E-lst2 over my house and off a 100ft dune with no worries b/c they are for fun and thats why I got them. Sometimes sh*t goes wrong! Its part of it.


mycarisaser is offline  
Old 05-25-2008, 08:20 AM
  #316  
SavageX78
Senior Member
 
SavageX78's Avatar
 
Join Date: Feb 2007
Location: Laconia, NH
Posts: 1,157
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx


ORIGINAL: fisheydude

mf2mm5700: The motors do get hot, too hot to keep a finger on them, but they seem to be holding up fine. The batts I am using charge up to 10.2 volts or so... Could that be the cause of the problems? I really trust these maxamps batts are good, may-be too good? [sm=confused.gif]
I dont think that batts are bad. The motors just want more than they can handle.

You could try getting smaller pinions 17 or 18 tooth.
When I fried my first set of titans traxxas sent me 18 tooth and it helped my temps on everything.
And that was just dropping 1 tooth.
SavageX78 is offline  
Old 05-25-2008, 09:24 AM
  #317  
fisheydude
Senior Member
 
Join Date: Dec 2007
Location: bowling green, KY
Posts: 219
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

That's really good to know dude. I ordered 2 17t pinions several days ago that should be here tomorrow. I was worried the heat would be worse, I'm glad you told me that.
I got the 17t pinions and a wheelie bar. I hope the two less teeth will help it wheel stand. I don't need a lot of speed. I like jumping dirt hills and climbing, that's all about torque. I just hope these batts hold together today!
fisheydude is offline  
Old 09-06-2008, 03:10 PM
  #318  
JustForKicks
Junior Member
 
Join Date: Aug 2008
Location: Walnut, CA
Posts: 15
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

Sorry to bring back an old thread, but how can I tell if my motors or my ESC are messed up? I've had this problem a few weeks after I bought the Maxx. I would run it for a while and it ran perfectly fine. After a few minutes, it starts to twitch, turn, and accelerate by itself. The batteries and motors are pretty hot after run as well.

Also, can someone recommend some good batteries? I'm running on Venom 4200's and the shrink wrap on one of them is already coming off. I want some good run times and good power.
JustForKicks is offline  
Old 09-06-2008, 04:06 PM
  #319  
fisheydude
Senior Member
 
Join Date: Dec 2007
Location: bowling green, KY
Posts: 219
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

Any motor I have lost has ended up having little pieces of metal rattling around inside of it. I guess a bad esc can have several symptoms. It sounds like more of a glitch or interferance problem. I guess the esc can still make that stuff happen, I'm not a pro or anything though. May-be the esc is getting too hot.?.
You should check out the traxxas on-line community too. You can find more info on batts and issues there. Go to Traxxas.com and go to the community thing.
fisheydude is offline  
Old 11-20-2008, 02:35 PM
  #320  
fritz175
Member
 
Join Date: Feb 2008
Location: Ann arbor, MI
Posts: 42
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

Hey!
I have a quick question about Batteries.
I'm looking to get an E-Maxx soon but don't know what type/brand of batteries to get!
I'm looking for 7 cell Nihm batteries.

Thanks,
Andy
fritz175 is offline  
Old 11-20-2008, 03:51 PM
  #321  
mycarisaser
 
Join Date: Feb 2004
Location: Kitty Hawk, NC
Posts: 2,048
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

http://www.promatchracing.com/products.php?cat=4
When I was racing promatch battes were some of the best. I got well over 300+ cycles out of them and tons of power

spc also makes great batteries
http://www.spcracing.com/index.php?categoryID=4

Just stay away from the venom and ebay batteries (the e-maxx pull way to much power for them and will cause them to blow up)

The top two links are some of the best and for a good price
mycarisaser is offline  
Old 11-20-2008, 03:59 PM
  #322  
fritz175
Member
 
Join Date: Feb 2008
Location: Ann arbor, MI
Posts: 42
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

what kind of run times can you get out of these?
fritz175 is offline  
Old 11-20-2008, 04:16 PM
  #323  
mycarisaser
 
Join Date: Feb 2004
Location: Kitty Hawk, NC
Posts: 2,048
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

Runtime depends on how you run but best estamate would be 20 to 25 mins(of course depending on how you drive).
mycarisaser is offline  
Old 11-20-2008, 08:13 PM
  #324  
BigBrett
 
BigBrett's Avatar
 
Join Date: Nov 2006
Location: Newport News, VA
Posts: 276
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 16.8V New E-maxx

check out these as well these guys make some of the best !! SMC Batteries
http://www.smc-racing.com/energ.html
BigBrett is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.