RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

The Official Traxxas Slash short-course race truck

Reply
Old 04-06-2012, 09:05 AM
  #2976
hound54
 
Join Date: May 2011
Location: vancouver, BC, CANADA
Posts: 224
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

You can take the body off or what I do fr 50 plus is take a plastic pop bottle cut out a piece of the middle long ways to make a wing and put it on the front body mounts .or tape a pad lock unde the front bumper if your just drag racing



hound54 is offline  
Reply With Quote
Old 04-06-2012, 09:44 AM
  #2977
DriftingDragon
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck


Quote:
ORIGINAL: momogt

what should i use for some weight up front to keep my truck from wheeling @ full throttle when onroad bashing
if your using nickel batteries get it opened up and put as many at the front as u can
DriftingDragon is offline  
Reply With Quote
Old 04-06-2012, 10:34 AM
  #2978
rayndog3
 
Join Date: Jan 2011
Location: West Warwick, RI
Posts: 391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

got the Gforce motor in today, very fast shipping, ordered tuesday and received it today. that was their standard $3.99 shipping. unfortunately Ican't try it out as of yet, I need to put 4mm bullets on it cause it ships with 3.5mm, and the soldering iron I use is at work. So It'll have to wait till monday.


rayndog3 is offline  
Reply With Quote
Old 04-09-2012, 10:33 AM
  #2979
rayndog3
 
Join Date: Jan 2011
Location: West Warwick, RI
Posts: 391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Ran the slash with the GForce in today. Used a gens ace 2s 40c 5000mah with 17/86 gears. Ran for about a half hour, the hottest the motor got was 108 degrees and seemed very smooth. I'm ginna try it out with 3s tomorrow as long as I doesn't rain.


rayndog3 is offline  
Reply With Quote
Old 04-09-2012, 05:14 PM
  #2980
DriftingDragon
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

nice whats the torque like on it?
DriftingDragon is offline  
Reply With Quote
Old 04-09-2012, 06:20 PM
  #2981
hound54
 
Join Date: May 2011
Location: vancouver, BC, CANADA
Posts: 224
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Hey it looks great but...you may have the same problem I am having with the venom 3300 kv.....that Bearing is exposed to dirt dust and whatever else.i m thinking of putting a sticker or something over it to keep the crud out.
hound54 is offline  
Reply With Quote
Old 04-09-2012, 06:28 PM
  #2982
rayndog3
 
Join Date: Jan 2011
Location: West Warwick, RI
Posts: 391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck


Quote:
ORIGINAL: hound54

Hey it looks great but...you may have the same problem I am having with the venom 3300 kv.....that Bearing is exposed to dirt dust and whatever else.i m thinking of putting a sticker or something over it to keep the crud out.
All 3 brushless motors I have the rear bearing is like that ( hobbywing, tacon, gForce) , haven't had any problems yet with my other 2. I have heard about putting a sticker on there before, just never did.

rayndog3 is offline  
Reply With Quote
Old 04-09-2012, 06:38 PM
  #2983
hound54
 
Join Date: May 2011
Location: vancouver, BC, CANADA
Posts: 224
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Oh yah o does it run by the way?

hound54 is offline  
Reply With Quote
Old 04-09-2012, 07:01 PM
  #2984
rayndog3
 
Join Date: Jan 2011
Location: West Warwick, RI
Posts: 391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck


Quote:
ORIGINAL: hound54

Oh yah o does it run by the way?
Huh, does what run?

@driftingdragon- there seems to be more torque than the tacon I was running, but I also had a17t pinion on it and I was running a 19t pinion on the tacon, so maybe hat was some of the difference I see.. But I did run it briefly tonight with a 3s and it really seemed to wake this motor up torque wise. Using the "eye" test it just seemed to have more balls. So far I would say great for the money, we'll see what happens long term.

rayndog3 is offline  
Reply With Quote
Old 04-09-2012, 07:07 PM
  #2985
hound54
 
Join Date: May 2011
Location: vancouver, BC, CANADA
Posts: 224
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Sorry typo ...how does  the motor run ..but you just answered my ?
hound54 is offline  
Reply With Quote
Old 04-09-2012, 07:34 PM
  #2986
DriftingDragon
 
Join Date: Jul 2006
Location: markham, ON, CANADA
Posts: 1,103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

nice, i need a better motor 2pole sucks
DriftingDragon is offline  
Reply With Quote
Old 04-09-2012, 07:38 PM
  #2987
rayndog3
 
Join Date: Jan 2011
Location: West Warwick, RI
Posts: 391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

I'll see if I can get a short vid up sometime tomorrow afternoon.
rayndog3 is offline  
Reply With Quote
Old 04-10-2012, 03:23 PM
  #2988
rayndog3
 
Join Date: Jan 2011
Location: West Warwick, RI
Posts: 391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Here's a short vid I shot with my iPhone of the slash withth gforce motor. This is on 3s. After the five minutes of running I try to show you the temp of the motor. So far I'm loving this motor!

[youtube]http://www.youtube.com/watch?v=6wAoqwCUSog&sns=em[/youtube]
rayndog3 is offline  
Reply With Quote
Old 04-10-2012, 04:37 PM
  #2989
brianjskora
 
brianjskora's Avatar
 
Join Date: Dec 2009
Location: , VA
Posts: 428
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Nice vid. I cant wait to get it in my 4x4 to try. Im not expecting it to be like my castle 1410, but as long as it outperforms the velineon ill be happy.

Selling a Slash 2wd Roller on the BAY if anyone is interested. Its got the STRC LCG kit, and comes with tires. Starts at $89.99

http://www.ebay.com/itm/260999357518...84.m1586.l2649

Selling it because between my stock chassis 2wd and my 4x4, I dont run it much.
Attached Thumbnails
Click image for larger version

Name:	Nl30010.jpg
Views:	13
Size:	79.0 KB
ID:	1749086  
brianjskora is offline  
Reply With Quote
Old 04-15-2012, 09:43 AM
  #2990
54Slash4X4
 
Join Date: Apr 2012
Location: North Tonawanda, NY
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

hey guys Im new to the forums and new to the hobby.  I dont know a whole lot yet so go easy on me lol.  I recently bought a slash and its been awesome so far. Last time I ran it was friday night and then yesterday it didnt seem to want to roll forward at all. It almost seems as if something is locked up but the wheels all spin fine when I spin them seperately. Its just if I put the car down and push it, it doesnt wanna move.  If anyone knows what this may be please help me out. 
54Slash4X4 is offline  
Reply With Quote
Old 04-15-2012, 09:46 AM
  #2991
thehuntingterminator
 
Join Date: Jul 2010
Location: Tyler TX
Posts: 3,549
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck


Quote:
ORIGINAL: 54Slash4X4

hey guys Im new to the forums and new to the hobby. I dont know a whole lot yet so go easy on me lol. I recently bought a slash and its been awesome so far. Last time I ran it was friday night and then yesterday it didnt seem to want to roll forward at all. It almost seems as if something is locked up but the wheels all spin fine when I spin them seperately. Its just if I put the car down and push it, it doesnt wanna move. If anyone knows what this may be please help me out.
have you made sure that all the electronics are working properly, like the motor isn't burned up? is it brushed or brushless?
thehuntingterminator is offline  
Reply With Quote
Old 04-15-2012, 10:03 AM
  #2992
54Slash4X4
 
Join Date: Apr 2012
Location: North Tonawanda, NY
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

All the electronics seem to work. Ibreifly turned it on and pulled the trigger and the wheels spun no problem. as soon as I let off they stopped like Iwas pushing the brake when I wasnt. Oh and its brushless
Quote:
ORIGINAL: thehuntingterminator


Quote:
ORIGINAL: 54Slash4X4

hey guys Im new to the forums and new to the hobby. I dont know a whole lot yet so go easy on me lol. I recently bought a slash and its been awesome so far. Last time I ran it was friday night and then yesterday it didnt seem to want to roll forward at all. It almost seems as if something is locked up but the wheels all spin fine when I spin them seperately. Its just if I put the car down and push it, it doesnt wanna move. If anyone knows what this may be please help me out.
have you made sure that all the electronics are working properly, like the motor isn't burned up? is it brushed or brushless?
54Slash4X4 is offline  
Reply With Quote
Old 04-15-2012, 10:16 AM
  #2993
thehuntingterminator
 
Join Date: Jul 2010
Location: Tyler TX
Posts: 3,549
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck


Quote:
ORIGINAL: 54Slash4X4

All the electronics seem to work. I breifly turned it on and pulled the trigger and the wheels spun no problem. as soon as I let off they stopped like I was pushing the brake when I wasnt. Oh and its brushless
Quote:
ORIGINAL: thehuntingterminator


Quote:
ORIGINAL: 54Slash4X4

hey guys Im new to the forums and new to the hobby. I dont know a whole lot yet so go easy on me lol. I recently bought a slash and its been awesome so far. Last time I ran it was friday night and then yesterday it didnt seem to want to roll forward at all. It almost seems as if something is locked up but the wheels all spin fine when I spin them seperately. Its just if I put the car down and push it, it doesnt wanna move. If anyone knows what this may be please help me out.
have you made sure that all the electronics are working properly, like the motor isn't burned up? is it brushed or brushless?
which BL system? if it is one that has a drag brake it sounds like that may have turned on for some reason.
thehuntingterminator is offline  
Reply With Quote
Old 04-15-2012, 10:24 AM
  #2994
54Slash4X4
 
Join Date: Apr 2012
Location: North Tonawanda, NY
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Its the stock system that comes in the slash vxl
54Slash4X4 is offline  
Reply With Quote
Old 04-15-2012, 10:26 AM
  #2995
thehuntingterminator
 
Join Date: Jul 2010
Location: Tyler TX
Posts: 3,549
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck


Quote:
ORIGINAL: 54Slash4X4

Its the stock system that comes in the slash vxl
then there is something mechanically wrong.
thehuntingterminator is offline  
Reply With Quote
Old 04-15-2012, 05:55 PM
  #2996
brianjskora
 
brianjskora's Avatar
 
Join Date: Dec 2009
Location: , VA
Posts: 428
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

You're gear mesh is off, or you blew out your slipper clutch bearing. Take off the cover and look at the spur and pinion. See if the mesh looks correct, and see it either the spur or pinion have play.
brianjskora is offline  
Reply With Quote
Old 04-22-2012, 05:51 AM
  #2997
brianjskora
 
brianjskora's Avatar
 
Join Date: Dec 2009
Location: , VA
Posts: 428
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Here is a video of four slash 4x4s racing on my new track

2 are running toro sc 4x4 motor/esc
1 is running the castle 1410 and MMP
1 is running velineon and mmp

[youtube]http://www.youtube.com/watch?v=-p5mnJGMtXo[/youtube]
brianjskora is offline  
Reply With Quote
Old 04-22-2012, 06:10 AM
  #2998
phmaximus
 
phmaximus's Avatar
 
Join Date: Jun 2008
Location: Adelaide, AUSTRALIA
Posts: 6,636
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

lol..... Now thats cool.
phmaximus is offline  
Reply With Quote
Old 04-23-2012, 11:50 AM
  #2999
54Slash4X4
 
Join Date: Apr 2012
Location: North Tonawanda, NY
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

So today I went to play with my Slash and for some reason the light on the receiver box was blinking red fast and it seemed like when I pulled the accelerator it seemed like I wasnt getting full power. Then when I hit the brake it didnt stop.  I dont have a clue what this could be. Can anyone point me in the right direction?
 
54Slash4X4 is offline  
Reply With Quote
Old 04-23-2012, 11:53 AM
  #3000
brianjskora
 
brianjskora's Avatar
 
Join Date: Dec 2009
Location: , VA
Posts: 428
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: The Official Traxxas Slash short-course race truck

Reset throttle points, sounds like they could be off
brianjskora is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:20 AM.