Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Dec 2007
    Location
    Cabot, AR
    Posts
    2
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Traxxas Slash Motor Problems

    Oh i really need some help here. I am new to electric, but have been running RC for about 4 years now. I have a slash and have burnt up 3 motors in 1 week. The first was a mamba max with a 7700, the second was a mamba max with a 5700, and the final one was a brushed motor. All of the had a 2 cell lipo running on them. The mamba's used the same ESC, then of course changed to the factor ESC. All 3 of them have went out the same way, lots of smoke.What could i be missing here. Anyone else having problems with these things. Thanks for the help!

  2. #2
    Brainanator's Avatar
    Join Date
    Jun 2009
    Location
    Great Falls, MT
    Posts
    2,482
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Traxxas Slash Motor Problems

    the 7700 is way too many kv for the slash. That overheated quickly and thus gave out quickly. The 5700 is still pretty high for a slash...If you don't gear way down or just do a few sprints at a time it's no wonder that one gave out as well. I'm running a 4600 mamba in my slash, and it still get's pretty warm at 16/86 gearing. As for the brushed motor, it depends on what it was, if it was the stock titan, those suck anyway. Pick up a VXL motor, at 3500kv it has much more torque, you can gear it higher and there will be less heat issues.
    OFNA Jammin CRT.5e, stock sprint 2 drift, Savage Flux (4S), slash (just a roller for now)

  3. #3
    rebuilder's Avatar
    Join Date
    Jan 2008
    Location
    Ark, AR
    Posts
    1,917
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Traxxas Slash Motor Problems

    Dont just give up on brushless yet. As Brain pointed out, 7700kv is off the chart for offroad...........5700kv is still too high in my book. I would go with a Traxxas Velineon 3500kv first and the castle 4600kv as a second choice. Also is there anything binding...........did you clamp down the pinion onto the spur way too tight? Check to see if everything turns freely with your hand. Whatever motor you run, gear it down a bit........big top speed is really not all its cracked up to be, you usually run out of room anyways. I like the "low geared get out of the hole quick" setups myself.

    P.S. - i could start a whole thread just using quotes from guys saying things like - "my 9000kv fried in my Pede, need help"...........etc. High kv's are for on-road and Drag racing IMO
    When in doubt, Overvolt it!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 09:22 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.