RC Flight Simulator Software Discuss rc flight simulator software here. Aerofly Pro, RealFlight G3, XTR, Reflex, etc.

Phoenix And Airtronics SD-10G

Reply

Old 01-16-2012, 02:23 PM
  #1  
Maxdog.vf213
Thread Starter
My Feedback: (1)
 
Maxdog.vf213's Avatar
 
Join Date: Oct 2011
Location: Palatine, IL
Posts: 120
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Phoenix And Airtronics SD-10G

Hey Guys!

Ok So I just got my brand new Airtronics SD-10G the other day and I am still learning everything but Ido know that there is no adapter for this radio phoenix has but Idid find a bunch of links to making your own, so Idid and it works but for some reason My throttle is the the Ails and My Ails are the throttle, tried reversing wires and so on but nothing is working.. Anyone know what to do here? Any advice at all?

Thanks Guys..
Maxdog.vf213 is offline  
Reply With Quote
Old 02-08-2012, 08:18 AM
  #2  
TotalWreck
Member
 
Join Date: Oct 2009
Location: Mount Airy, NC
Posts: 66
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Phoenix And Airtronics SD-10G

Just make sure you start off with a clear model, in your radio and setup as 1 servo. All mixing setup is done in phoenix. Your homade wire will work till you can do better. Keep fiddleing wih phoenix you'll get it.
TotalWreck is offline  
Reply With Quote
Old 02-22-2012, 03:47 PM
  #3  
Maxdog.vf213
Thread Starter
My Feedback: (1)
 
Maxdog.vf213's Avatar
 
Join Date: Oct 2011
Location: Palatine, IL
Posts: 120
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Phoenix And Airtronics SD-10G

Still having issues, not sure if anyone can be more clear, everything is running backwards, Left stick controling Ails and Elivator and visa versa.. How do Iset it up in the radio if thats the issue? Kinda new with it so not 100% clear on all the settings..

Thanks,
Maxdog.vf213 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service