RC Giant Scale Cars For all those who love driving large scale rc cars share your projects or ask questions here.

Alloy engine mount stripped

Reply

Old 07-25-2007, 12:37 PM
  #1  
csp1971
Thread Starter
 
csp1971's Avatar
 
Join Date: Aug 2006
Location: Blue Springs, MO
Posts: 503
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Alloy engine mount stripped

Okay, I have the large alloy engine mount on my Firehammer MT. The screw that goes through the rear bulkhead brace into the mount is stripped. I cannot find a longer screw to go into hole since it isn't that deep. I had it locktighted originally, but it would continue to loosen. Now, it just won't tighten. Should I use a larger screw? Is there any other way to repair this? These mounts cost enough money, I'm a bit disappointed that this has already gone bad.
csp1971 is offline  
Reply With Quote
Old 07-25-2007, 12:40 PM
  #2  
sb racing
Senior Member
 
Join Date: May 2005
Location: Birmingham, UNITED KINGDOM
Posts: 175
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Alloy engine mount stripped

You will need to re-tap the hole to m5 thread and use an m5 bolt instead of an m4.

I hope this helps.

Simon
sb racing is offline  
Reply With Quote
Old 07-25-2007, 01:31 PM
  #3  
hellya
Senior Member
 
hellya's Avatar
 
Join Date: Feb 2005
Location: Bonney Lake, WA
Posts: 4,202
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Alloy engine mount stripped


ORIGINAL: sb racing

You will need to re-tap the hole to m5 thread and use an m5 bolt instead of an m4.

I hope this helps.

Simon

yep retap it to a larger bolt size
hellya is offline  
Reply With Quote
Old 07-25-2007, 03:25 PM
  #4  
csp1971
Thread Starter
 
csp1971's Avatar
 
Join Date: Aug 2006
Location: Blue Springs, MO
Posts: 503
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Alloy engine mount stripped

Thanks guys, I'll give that a try!

csp
csp1971 is offline  
Reply With Quote
Old 07-25-2007, 03:58 PM
  #5  
kidd
Senior Member
 
Join Date: Nov 2004
Location: , MO
Posts: 551
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Alloy engine mount stripped

be careful with the drill those mounts are a soft cheap aluminum.
kidd is offline  
Reply With Quote
Old 07-25-2007, 06:23 PM
  #6  
slicrick
Senior Member
 
Join Date: Nov 2006
Location: milpitas, CA
Posts: 251
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Alloy engine mount stripped

just drill it out and use a m4 helicoil then you can still use the m4 screw
slicrick is offline  
Reply With Quote
Old 07-25-2007, 07:43 PM
  #7  
csp1971
Thread Starter
 
csp1971's Avatar
 
Join Date: Aug 2006
Location: Blue Springs, MO
Posts: 503
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Alloy engine mount stripped

Tapped it with an M5. Worked perfect, thanks guys.
csp1971 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service