RC Giant Scale Cars For all those who love driving large scale rc cars share your projects or ask questions here.

King Motor T1000 Baja Truck

Reply

Old 12-20-2011, 08:52 AM
  #651  
willclark77
My Feedback: (2)
 
willclark77's Avatar
 
Join Date: Apr 2009
Location: Hattiesburg, MS
Posts: 356
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: King Motor T1000 Baja Truck


ORIGINAL: magnum500

here are some pics

this is what comes with the pipe everything needed to make it work
[img][/img]
Congrats! Let us know how it compares to the rear dom. I never bought one of these cause it looked like it would be a pita to work around.
willclark77 is offline  
Reply With Quote
Old 12-20-2011, 09:36 AM
  #652  
magnum500
Senior Member
 
Join Date: Mar 2006
Location: amherstburg, ON, CANADA
Posts: 467
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: King Motor T1000 Baja Truck

It is a bit of a pain to charge bats. Still totally doable just not out in the open like it was
magnum500 is offline  
Reply With Quote
Old 12-20-2011, 07:17 PM
  #653  
osnitro
Senior Member
 
osnitro's Avatar
 
Join Date: Dec 2005
Location: somewhere in, NY
Posts: 159
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: King Motor T1000 Baja Truck

magnum500, the new pipe looks great, now let hear it come to life!
osnitro is offline  
Reply With Quote
Old 12-20-2011, 08:15 PM
  #654  
magnum500
Senior Member
 
Join Date: Mar 2006
Location: amherstburg, ON, CANADA
Posts: 467
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: King Motor T1000 Baja Truck

i did fire it up in the garage today , it does have a nice tune . not as raspy as the old one . i`m going to try to get some video this week
magnum500 is offline  
Reply With Quote
Old 02-13-2014, 10:54 AM
  #655  
Greg in Tennessee
Junior Member
 
Join Date: Feb 2014
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hey i'm not trying to get into this debate about wich is better.Im just trying to find out if any of you guys have had a king moter baja t1000 for any length of time and had success with the kit please.Without sinking a bunch of money in it.
Greg in Tennessee is offline  
Reply With Quote
Old 02-13-2014, 01:29 PM
  #656  
wojtek
My Feedback: (72)
 
wojtek's Avatar
 
Join Date: Dec 2001
Location: nj, NJ
Posts: 4,234
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The t100 is OK. The engine is also ok. There is a clear quality diference with the HPI bran trucks, but you do get a good $ worth with the t1000. We have beat ours up quite a bit, and it keeps running ... The pull starter did need replacing a few times however .


Voy
wojtek is offline  
Reply With Quote
Old 02-13-2014, 02:15 PM
  #657  
magnum500
Senior Member
 
Join Date: Mar 2006
Location: amherstburg, ON, CANADA
Posts: 467
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by wojtek View Post
The t100 is OK. The engine is also ok. There is a clear quality diference with the HPI bran trucks, but you do get a good $ worth with the t1000. We have beat ours up quite a bit, and it keeps running ... The pull starter did need replacing a few times however .


Voy
I agree with wojtec , my truck has been running for some time now , the pull start is on its way out . the steering servo grenaded , other than that its still going good . I also have a dominator pipe on mine too . I`d say there is good value in these trucks . there has been horror stories of some who bought these and had nothing but trouble . I purchased mine from a person who was very particular with his sales of the trucks , I guess he`d inspect all he sold for any visual problems . if there was any trouble with a truck he sold he tried to make it right . the real question is would I buy another ???? without a doubt I would . feel free to ask any questions .
magnum500 is offline  
Reply With Quote
Old 02-19-2014, 06:50 AM
  #658  
Greg in Tennessee
Junior Member
 
Join Date: Feb 2014
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

So whats the deal with the pull start?Is it the rope or the mech. itself?I saw a video of a guy starting his with a drill.
Greg in Tennessee is offline  
Reply With Quote
Old 02-19-2014, 08:54 AM
  #659  
magnum500
Senior Member
 
Join Date: Mar 2006
Location: amherstburg, ON, CANADA
Posts: 467
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

For me it seems like the recoil spring itself will be the trouble.
magnum500 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service