RC Helicopter Beginners Forum If you are a beginner or "newbie" to RC heli's feel free to post your questions right here in the rc heli beginner forum.

Align Trex 450L Gyro help (MicroBeast Plus)

Reply

Old 11-11-2016, 03:45 PM
  #1  
sweinhart2006
Thread Starter
 
Join Date: Jun 2009
Location: Aloha, OR
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Align Trex 450L Gyro help (MicroBeast Plus)

After 2 days of testing and corrections, I finally have the thing mostly stable in the air. I have ensured my setup was good both linkages and main setup. The final corrections I need help with involve tail gyro sensitivities. After much trial and error, I found a setting(pre-torque compensation) that had to be set to maximum, or the heli would spin endlessly to the left. Now comes in the gyro sensitivity. The unit runs from -100 to +100, with negative values equating to normal mode and positive values equating to heading lock. I use a futaba radio whose range is 0 to 100, which means values above 50 are heading lock and below 50 are normal. Anything less than 58.5, the heli will start to spin slowly to the left. and the rate of rotation increases as you decrease the gyro sensitivity. At 58.5, this spin is mostly stopped, although small cyclic inputs often causes slight drift of yaw to the left. The problem is that at this point, the tail also starts to wag(typical of too high a value) and it gets worse the higher you increase it. I've tried playing with pot number 3 which didn't seem to make any difference on either ends of the spectrum. Something's not right because I have never had this problem on other gyros for helicopters. Admittedly though, I can't even make the gyros in my planes work for the same problem. I always got tail wag or a sluggish tail, so I just took them out. Just keep in mind, that the system they designed offloads all mixing functions including swashplate configuration and revo-mixing, so all radio mixing functions are supposed to be turned off.
sweinhart2006 is offline  
Reply With Quote
Old 03-17-2019, 06:51 AM
  #2  
MarkJP
Junior Member
 
Join Date: Mar 2019
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hello, were you able to fix this issue? i am having the same problem
MarkJP is offline  
Reply With Quote
Old 03-17-2019, 11:02 AM
  #3  
A. J. Clark
 
A. J. Clark's Avatar
 
Join Date: Mar 2004
Location: Craigville, IN
Posts: 410
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Make sure the tail slider works smoothly.

Adjust the tail linkage in rate mode first. Then go to hh mode.

If that doesnt work your control arms may be to short or to long.
A. J. Clark is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service