RC Jets Discuss RC jets in this forum plus rc turbines and ducted fan power systems

12X battery issue

Reply

Old 04-15-2012, 06:29 PM
  #1  
sideshow
Thread Starter
My Feedback: (11)
 
sideshow's Avatar
 
Join Date: Nov 2001
Location: Pleasanton, CA
Posts: 3,155
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default 12X battery issue

I searched all the past posts and didn't seem to find what I was looking for. I turned my 12X on today hoping to fly and the screen kind of just blinked continuously. I tried to charge the battery with my Hyperion 720 duo...but I got an error. I put the charge lead in the pack and used a multi-meter and the other end (banana plugs) and it read 10.3 volts. Needless to say I went home. I put an old 10X pack in and it powered right up, though none of the memory was there.....which sucks. I resoldered the board of the 10X pack to the NiMH of the New(er) 12X pack and all seems to be well....notwithstanding all the lost memory.

I've read that the newer cassettes had a fuse instead of a diode for the older 10X packs. Would a failure of the fuse on the board wipe out the memory in the Tx? Has anyone else experienced this?

I ask because I hesitate to reuse the old board (diode) with the 12X if if weren't meant for it. I also hesitate to buy a new pack just to change it out to eneloops (which is the plan).

I'd appreciate any experience anyone has....
sideshow is offline  
Reply With Quote
Old 04-15-2012, 06:58 PM
  #2  
KC36330
 
Join Date: Apr 2006
Location: Enterprise, AL
Posts: 5,952
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

if your screen just blinked it's low voltage. just get the Eneloops and install them and it should be fine.

nothing should wipe the memory though, it's flash based and doesn't require a keep alive voltage.
KC36330 is offline  
Reply With Quote
Old 04-15-2012, 07:33 PM
  #3  
SinCityJets
Senior Member
 
Join Date: Nov 2005
Location: Henderson, NV
Posts: 2,778
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

No problem using the board from the 10X, in the 12x. They are IDENTICAL. After having swapped out over 500 packs, I can telly you they are completely interchangeable.

Chad
SinCityJets is offline  
Reply With Quote
Old 04-15-2012, 07:53 PM
  #4  
sideshow
Thread Starter
My Feedback: (11)
 
sideshow's Avatar
 
Join Date: Nov 2001
Location: Pleasanton, CA
Posts: 3,155
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue


ORIGINAL: KC36330

if your screen just blinked it's low voltage. just get the Eneloops and install them and it should be fine.

nothing should wipe the memory though, it's flash based and doesn't require a keep alive voltage.
The problem is it did......model memory is gone.
sideshow is offline  
Reply With Quote
Old 04-16-2012, 01:16 AM
  #5  
rolsen12
Senior Member
 
Join Date: May 2007
Location: Oak Creek, WI
Posts: 305
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

My 12X does the same thing.I have two packs, one Eneloop and one JR.I think that this is caused by low temp. Once the voltage gets about 10.4 volts the screen will flash once
and then turn on. Any lower in the voltage and only the landing gear default in the up position will let the screen come on. Ehen the gear switch is in the down position the screen will juist flash, but the transmitter will not turn on. I think I will have to buy a new transmitter, and transfer the info tothe new one. I can not trust this one any farther than I can through it.
rolsen12 is offline  
Reply With Quote
Old 04-16-2012, 04:09 AM
  #6  
Jetpilot24
My Feedback: (21)
 
Join Date: Jan 2003
Location: Niles, OH
Posts: 1,281
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

ORIGINAL: sideshow

I searched all the past posts and didn't seem to find what I was looking for. I turned my 12X on today hoping to fly and the screen kind of just blinked continuously. I tried to charge the battery with my Hyperion 720 duo...but I got an error. I put the charge lead in the pack and used a multi-meter and the other end (banana plugs) and it read 10.3 volts. Needless to say I went home. I put an old 10X pack in and it powered right up, though none of the memory was there.....which sucks. I resoldered the board of the 10X pack to the NiMH of the New(er) 12X pack and all seems to be well....notwithstanding all the lost memory.

I've read that the newer cassettes had a fuse instead of a diode for the older 10X packs. Would a failure of the fuse on the board wipe out the memory in the Tx? Has anyone else experienced this?

I ask because I hesitate to reuse the old board (diode) with the 12X if if weren't meant for it. I also hesitate to buy a new pack just to change it out to eneloops (which is the plan).

I'd appreciate any experience anyone has....
I had the exact same thing happen on my 12x. I had a blinking screen after the Tx was in the back of my truck on a very cold day returning from the field.

What I did was plug a another battery in to it while the power switch was on. After that the radio worked but would not hold any memory and not hold the selected model. I ended up sending it to Horizon and they replaced the IP board I believe. This iss the part of the radio that downloads any changes to memory. It was under warranty. From the time that I shipped it till i received it back was about 3 weeks. If yours is not holding memory then you most likely have the same problem and it will have to go in for service. I have been using the Tx since flying all of my jets and my giant scale. I have had no issues since the repair.
Good luck
Joe Lewis
Kingtech
K-80 and K-140
Owner
Jetpilot24 is offline  
Reply With Quote
Old 04-16-2012, 05:48 AM
  #7  
PaulD
My Feedback: (39)
 
PaulD's Avatar
 
Join Date: Apr 2002
Location: Coquitlam, B.C., CANADA
Posts: 1,391
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

I would send it in .....

PaulD
PaulD is offline  
Reply With Quote
Old 04-16-2012, 10:45 AM
  #8  
AFTERBURNER1
My Feedback: (80)
 
AFTERBURNER1's Avatar
 
Join Date: Jun 2003
Location: Anaheim Hills, CA
Posts: 4,424
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

Internal memory batt dead??? Buy new TX pack. Padlock. Uhhh.
AFTERBURNER1 is offline  
Reply With Quote
Old 04-16-2012, 11:57 AM
  #9  
Jack Diaz
My Feedback: (1)
 
Join Date: Nov 2003
Location: Caracas, VENEZUELA
Posts: 528
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue


ORIGINAL: PaulD

I would send it in .....

PaulD
+1
Jack Diaz is online now  
Reply With Quote
Old 04-16-2012, 02:05 PM
  #10  
bonanzadrv
My Feedback: (21)
 
Join Date: Jan 2002
Location: Joliet, IL
Posts: 268
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

Now that Dssm is out your 12x wont work.......
I am afraid to turn mine on

Bill
bonanzadrv is offline  
Reply With Quote
Old 04-16-2012, 03:03 PM
  #11  
KC36330
 
Join Date: Apr 2006
Location: Enterprise, AL
Posts: 5,952
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

ORIGINAL: AFTERBURNER1

Internal memory batt dead???
12x doesn't use the internal lithium battery, it's not needed with the flash based memory.
KC36330 is offline  
Reply With Quote
Old 04-16-2012, 03:08 PM
  #12  
Jack Diaz
My Feedback: (1)
 
Join Date: Nov 2003
Location: Caracas, VENEZUELA
Posts: 528
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

Quote
Now that Dssm is out your 12x wont work.......
I am afraid to turn mine on

Bill
Quote








Bill, they are alive !!!!!! LOL
Jack Diaz is online now  
Reply With Quote
Old 04-19-2012, 04:05 AM
  #13  
mick15
 
mick15's Avatar
 
Join Date: Apr 2002
Location: Essex, UNITED KINGDOM
Posts: 1,936
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 12X battery issue

Tell me has anyone got all 18 channels from the Powerbox Cockpit/ S.Bus setup, if so how?

m
mick15 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy