Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4

  1. #1

    Join Date
    Mar 2003
    Location
    Dubai, UNITED ARAB EMIRATES
    Posts
    302
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    G Booster 80+ start issues



    Hi Guys.
    I live in Dubai and have recently brought a new G booster 80+ turbine and installed it in my Boomerang Sprint.
    I have had 5 flights with it and it has gone like a dream. OAT has been in the mid to high 30c.
    Today I started it as usual and it was a bit rough and spluttery and then at the idle point it went woof and shut down with a big cloud of white smoke.
    I let it cool down and checked everything, all was ok, and no errors on the Hand held terminal.
    On restart it ran up and settled into a good idle, and I ran it to full power and back, all was ok.
    taxied out and at run up prior to take off at half throttle it did the same thing, woof and big cloud of white smoke.
    We adjusted the acc ramp from default 23 sec to 33 sec and it started again, but after going full throttle and back to idle, and up to half throttle acceleration it still did it, and again at acc ramp 35 secs.

    some stats for you.

    OAT 32c, high humidity.

    ECU is all default except acc ramp at 33 secs.
    limits
    ídle- 4900
    100% - 16400
    EGT av 510c
    EGT peak 753c.
    RPM min /max 34800/164200.
    last off, run R
    r/c fails, 0.
    Total runs 11 ( 4 today)
    start aborts, 2
    Run aborts, 2
    Hr meter, 51.33 min
    Engine s/n, 09041 4.53
    ECU Firmware, Jetronics vxg3.22.

    ECU battery is the supplied 2500 Li Ion battery, fully charged.Fuel supply is ok as it will go to full throttle and sit there ok.

    I am aware of issues with the larger G boosters not running in high humidity, but was assured that the smaller turbines were ok.

    Any advise please?

    Thanks
    Darryl J

    I used to land in English cow poo, now I land in Camel poo. Plane still smells the same though.

  2. #2
    SJN's Avatar
    Join Date
    Sep 2002
    Location
    Copenhagen, DENMARK
    Posts
    6,038
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: G Booster 80+ start issues

    Have you checked your fuel filter ?
    Sonnich Johannesen

  3. #3
    darryltarr's Avatar
    Join Date
    Nov 2002
    Location
    Dubai, UNITED ARAB EMIRATES
    Posts
    191
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: G Booster 80+ start issues

    Hi Darryl,

    Check out this post:

    http://www.rcuniverse.com/forum/m_10...m.htm#10719107

    Although this post it is for the G-Booster 160, I believe the issues are similar to yours. After adjusting your ACC RAMP to 33 seconds this morning I forgot to check your THROTTLE TYPE, it should be set to SOFT.

    Just like my Booster 160+ on my BVM King Cat: THEY DO NOT LIKE VERY HUMID CONDITIONS.

    Good luck,

    Darryl Tarr
    (Dubai)

  4. #4

    Join Date
    Mar 2003
    Location
    Dubai, UNITED ARAB EMIRATES
    Posts
    302
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: G Booster 80+ start issues

    hi SJN.
    fuel filter is new and good, and hopefully not the problem.
    Darryl, just thought I would see what other people thought of this issue, because before I brought the engine I was assured that the issues were only on the larger engine.
    Its not a problem now I know,but nice to know if anyone else is experiencing the same thing with the smaller turbine.
    throttle is set to soft.
    hopefully will not be so humid next week and we can try again.
    See you then.

    Darryl J.

    I used to land in English cow poo, now I land in Camel poo. Plane still smells the same though.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:14 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.