Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1
    DAN AVILLA's Avatar
    Join Date
    Dec 2001
    Location
    roseville, CA
    Posts
    567
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    jet tronic brake valve problem?

    I have been doing this a long time and never had a problem finding a air leak . When flying my P 80 it looses most of the air in the brake system. I can not duplicate it on the ground. It holds air for 30 min with and without radio on.Gear up down. speed brake out. etc. The system has the speed brakes on it also so I was thinking the valve or rams might be the problem. I even heated the tanks with a blow gun thinking it was heat related. My question is has any one ever had a JT valve wack out. Thanks Dan

  2. #2
    wfield0455's Avatar
    Join Date
    Sep 2005
    Location
    Holliston, MA
    Posts
    384

    RE: jet tronic brake valve problem?

    No real answers, but a couple of questions. I assume you are using separate valves for the brakes and speed brake with a shared air tank?
    What JT valves are you using, dual ? The valve being the problem doesn't really seem very likely to me, I would expect the problem to be
    the cylinder for the speed brake or the brakes themselves which was your first thought as well. How are you activating the brakes ?
    Just wondering if they are activated by down elevator and perhaps the mix is somehow not being deactivated when the gear is retracted
    and they are using air each time down elevator is applied.. Would really need more info on how your system is plumbed, etc to offer more help.

    Wayne

  3. #3
    DAN AVILLA's Avatar
    Join Date
    Dec 2001
    Location
    roseville, CA
    Posts
    567
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: jet tronic brake valve problem?

    Wayne this is tough one. I'm useing a single JT valve. It is plumbed like you are thinking. One of the first things I looked at was a possable mix that was efecting my brake slider causeing it to come on a little and blow off the air. I do not use down elevator mix. When I work the controls and switches it does not efect that channel. I just tryed to flex all the lines to the robart for the SB .JT valve and air rams thinking it was caused by pulling G.s. I can push close the SB rams and still have no leaks. When it looses it the flight is only 6 min long. When I put the brakes on they lock up and hold air. I have a new valve , new rams and robart showing up next week. I think I will start with the valve. Thanks Dan
    ORIGINAL: wfield0455

    No real answers, but a couple of questions. I assume you are using separate valves for the brakes and speed brake with a shared air tank?
    What JT valves are you using, dual ? The valve being the problem doesn't really seem very likely to me, I would expect the problem to be
    the cylinder for the speed brake or the brakes themselves which was your first thought as well. How are you activating the brakes ?
    Just wondering if they are activated by down elevator and perhaps the mix is somehow not being deactivated when the gear is retracted
    and they are using air each time down elevator is applied.. Would really need more info on how your system is plumbed, etc to offer more help.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:49 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.