Go Back  RCU Forums > RC Airplanes > RC Jets
Reload this Page >

kingtech turbine rc engine k70g2 fatal problem

RC Jets Discuss RC jets in this forum plus rc turbines and ducted fan power systems

kingtech turbine rc engine k70g2 fatal problem

Reply

Old 11-06-2018, 12:03 PM
  #1  
isaacb
Thread Starter
 
Join Date: Jul 2005
Location: nez-ziona, ISRAEL
Posts: 21
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default kingtech turbine rc engine k70g2 fatal problem

Hello everyone,
Has anyone encountered a fatal malfunction with the Kingtech K70g2 engine?
Attached above pictures that describe the results.
I would like to point out that the case happened to another four engines of this kind (k70g) in Israel.
All of them had a FOD screen and yet it was a failure, in addition to another 2 turbines of the same series k70g were sent to repair due to ball bearings They failed. Customers in Israel are concerned that something is wrong with this engine. In the other models like k120,k140, we did not encounter such a problem.

Isaac Berman



isaacb is offline  
Reply With Quote
Old 11-06-2018, 12:12 PM
  #2  
ravill
My Feedback: (11)
 
ravill's Avatar
 
Join Date: Jan 2003
Location: Redwood City
Posts: 4,708
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Nasty stuff!
ravill is offline  
Reply With Quote
Old 11-06-2018, 12:14 PM
  #3  
why_fly_high
My Feedback: (19)
 
Join Date: Mar 2002
Location: Edmond, OK
Posts: 598
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

My friends and I have been running something like 8 of these. No failures like that.
why_fly_high is online now  
Reply With Quote
Old 11-06-2018, 12:36 PM
  #4  
Len Todd
 
Join Date: Jul 2012
Location: Baldwin, MI
Posts: 1,126
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

My bearing experience was on another model K, but it maybe similar issue: There is a bearing problem with K160 V2s. They admitted to the issue and we have had several Ks with failed bearings. I heard my bearings going bad on 3 sequential starts and sent it in for service after the third time. The repair order did not specify what was wrong, so I called. Apparently "there was a design problem." They replaced the entire core. But, I also noticed the start sequence changed. The start sequence now sounds like there is a short squirt of fuel shot into the turbine before it even turns over for the start (i.e. the pump runs for ~1 second before rolling over the spindle.) However, ...

It sure does look like something was ingested on your pics. but you indicated that there was a FOD. Are you sure it was tight to the cowl? If you had bearings going, from my experience it seems like you should have heard them during the start sequence. But then again, maybe not. I hate it when they come apart. I had a P-90 RXi come apart mid air. All sorts of internal damage but there was no damage to the first wheel's blades. But the last wheel was broken right off and kind of hanging out of the exhaust cone. But once the blades disintegrate, there is no telling what damage will result from the vibrations. Good luck.
Len Todd is online now  
Reply With Quote
Old 11-06-2018, 12:40 PM
  #5  
Auburn02
My Feedback: (1)
 
Join Date: May 2005
Posts: 574
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Could a bearing failure cause what's in the pics? I wouldn't expect any internal parts to come forward to cause damage to the blades like that, but I've never seen any such failures to have any first hand experience.

My K70G2 has had no issues whatsoever.
Auburn02 is offline  
Reply With Quote
Old 11-06-2018, 02:25 PM
  #6  
rhklenke
My Feedback: (24)
 
rhklenke's Avatar
 
Join Date: Jun 2002
Location: Richmond, VA
Posts: 5,673
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I've seen that type of damage on other motors before. A piece broke off one of the compressor blades and rattled around in there, damaging the other compressor blades.

On my motor (that did it twice) the piece was finally ejected out *through* the FOD screen. Initially, I thought it was a failure of the FOD screen and something had punched through and gotten in there. However, upon further close examination of the FOD screen, it was seen that the broken strands around the hole were bend *out* not *in*, indicating that the foreign object came from the compressor wheel itself and was launched *out* through the FOD screen.

This failure has become somewhat less prevalent now that must compressor wheels are machined from billet vs. being cast, but it still happens.

Bob

edit: the motors that I have seen this in were not Kingtechs....

Last edited by rhklenke; 11-06-2018 at 05:26 PM.
rhklenke is online now  
Reply With Quote
Old 11-06-2018, 05:06 PM
  #7  
more
 
Join Date: Feb 2011
Location: Chiangmai, THAILAND
Posts: 55
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

We have found this experience at least 3 motors in Thailand.All damaged motors were checked that FOD screen still been tight and not came apart.
These motors were sent to factory for repairing and have been sent back but the problem is happened again and again.
I noticed the compressor blade that engraved with KT marking may be broken first that make debris destroy motor.
I have reported the problem to Kingtech now and We ban K-70 at our flying club now until Kingtech will solve this problem.
I don't know why they still selling the K-70 model in KT website while they stop selling K-310 that have the same problem.




Last edited by more; 11-06-2018 at 05:16 PM.
more is offline  
Reply With Quote
Old 11-07-2018, 11:52 AM
  #8  
Desertlakesflying
My Feedback: (28)
 
Join Date: Jul 2005
Location: Sun Valley, NV
Posts: 2,453
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by why_fly_high View Post
My friends and I have been running something like 8 of these. No failures like that.
Wow, you promoting Kingtech like this...
Desertlakesflying is online now  
Reply With Quote
Old 11-07-2018, 11:59 AM
  #9  
why_fly_high
My Feedback: (19)
 
Join Date: Mar 2002
Location: Edmond, OK
Posts: 598
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by Desertlakesflying View Post
Wow, you promoting Kingtech like this...
Was I promoting anything?
why_fly_high is online now  
Reply With Quote
Old 11-07-2018, 12:02 PM
  #10  
Auburn02
My Feedback: (1)
 
Join Date: May 2005
Posts: 574
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by Desertlakesflying View Post
Wow, you promoting Kingtech like this...
You mad?
Auburn02 is offline  
Reply With Quote
Old 11-07-2018, 03:51 PM
  #11  
Desertlakesflying
My Feedback: (28)
 
Join Date: Jul 2005
Location: Sun Valley, NV
Posts: 2,453
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by Auburn02 View Post
You mad?
Awww look friends....

No it is called feeling sorry for people like you two.
Desertlakesflying is online now  
Reply With Quote
Old 11-07-2018, 04:08 PM
  #12  
LGM Graphix
My Feedback: (22)
 
LGM Graphix's Avatar
 
Join Date: Apr 2003
Location: Abbotsford, BC, CANADA
Posts: 5,368
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

All I can say is if I were certain manufactures I would be reconsidering my reps and / or dealers. This juvenile bull***** is enough to turn me off of a product. When I need product support this is not the level of service or professionalism I would expect.
LGM Graphix is online now  
Reply With Quote
Old 11-07-2018, 04:25 PM
  #13  
smaze17
My Feedback: (60)
 
Join Date: Dec 2001
Location: Cornelius, NC
Posts: 1,462
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Is this issue only affecting the 70g2? Any current issues with any of the other engine sizes? Barry?

Last edited by smaze17; 11-07-2018 at 04:28 PM.
smaze17 is online now  
Reply With Quote
Old 11-07-2018, 04:35 PM
  #14  
Sparhawk
 
Sparhawk's Avatar
 
Join Date: Aug 2002
Location: Truro, NS, CANADA
Posts: 587
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I have a friend with a K140 that did the same thing.. Whatever let go, it ejected out through the FOD screen as well as damaging internals. He sent it back and they blamed the damage on FOD, so they quoted him a nice repair bill. Needless to say, he said it was his first and last Kingtech turbine. He didn't need a company calling him a liar when evidence showed otherwise.
​​​​​​
Sparhawk is offline  
Reply With Quote
Old 11-07-2018, 05:32 PM
  #15  
Auburn02
My Feedback: (1)
 
Join Date: May 2005
Posts: 574
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by Desertlakesflying View Post
Awww look friends....

No it is called feeling sorry for people like you two.
Nah, I don’t know that guy. Don’t know you either, nor do I care. Just too easy to call out hypocrisy when I see it.

Last edited by Auburn02; 11-07-2018 at 07:54 PM.
Auburn02 is offline  
Reply With Quote
Old 11-07-2018, 06:52 PM
  #16  
NZjet
 
Join Date: Sep 2010
Location: , NEW ZEALAND
Posts: 73
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

If there is a design fault I would like to hope kingtech will take care of the problem. I personally have quite a few kingtechs without problems.
this reminds me of the wren 160 saga that bit many of us......
NZjet is offline  
Reply With Quote
Old 11-08-2018, 12:07 AM
  #17  
marquisvns
 
marquisvns's Avatar
 
Join Date: Oct 2005
Location: Pasadena, CA
Posts: 1,757
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Yes, we are having some K-70 compressor wheel problems, not all, but some. The factory is looking into the possible harmonic or some sort of sympathetic vibration induced damage to some of these wheels. The factory has a new design of the compressor, the initial testing with this new wheel yields a lower temperature and better thrust. So the new K-70 should have a lower full throttle RPM.

We are very sorry for the trouble and thank you for your patience for working with us.

Regards,
Barry
marquisvns is offline  
Reply With Quote
Old 11-08-2018, 12:08 AM
  #18  
marquisvns
 
marquisvns's Avatar
 
Join Date: Oct 2005
Location: Pasadena, CA
Posts: 1,757
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The testing process is lengthy, so no new engine will be delivered until further notice, thank you.

Barry

Last edited by marquisvns; 11-08-2018 at 12:12 AM.
marquisvns is offline  
Reply With Quote
Old 11-08-2018, 06:33 AM
  #19  
j.duncker
My Feedback: (2)
 
j.duncker's Avatar
 
Join Date: Jun 2004
Location: Sailing in the Eastern Caribbean
Posts: 3,960
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

LET'S KEEP THIS ONE POLITE GENTLEMEN. PLEASE STOP THE FLAME WAR NOW.

I want to keep this thread going as there is a probable issue and some RCU members will be concerned.
j.duncker is offline  
Reply With Quote
Old 11-08-2018, 07:09 AM
  #20  
Len Todd
 
Join Date: Jul 2012
Location: Baldwin, MI
Posts: 1,126
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks for updating us Barry. I know you guys are dependent on the factory to give us good products and that you guys really work hard to service these for us. Based on my experience, I don't think most folks would complain about your service quality or turn-around times. These products do cost a lot of $s. So there are some folks a turbine failure has a huge impact on.

For the rest of us watching this thread; Being successful in this aspect of the hobby pretty much depends on one's attitude. Ones attitude is a choice. Let me explain.

This "turbine failure" type of thing happens to many manufacturers' products, especially ones that are on the cutting edge of high-performance and technology! . I went thru three P-90RXIs before the manufacturer got them fixed. At the time, I clearly felt they were released to us prematurely. By the end of those P-90 experiences, I had already decided to try another brand, even though in the past, I typically had been very brand loyal. Then, I also watched a friend go thru 3 W-100s before he (and I) gave up on Wren even though Ron's service shop was only a couple hours down the road. I also had two brand new snow-machines that had harmonics occur at 6800 RPM. This would cause the engines to self-destruct. I also had a new truck that could not keep fuel injectors working. Ended up lemmoning it.

The one common thing to my experiences listed here was the products were all what I call "first year production models." I have come to the conclusion that if I do NOT want to be the product tester, never buy a product that is in its first year of production. On the other hand, if I am willing to deal with being the tester, then I will risk buying a first year production model and just deal with any failures. Unless you want to set yourself up for many disappointments, I feel that is a decision you have to make early with jets, . Given that all 7 turbines that I have owned have been back to the shop in their first few hours, I have come to the conclusion that we are the beta testers for all turbine manufacturers. If I was not willing to deal with that, I would be flying exclusively with props. Think about it, … how can a manufacturer test their engines in all the conditions we expose these engine to? If you are not willing to do the testing, … feel free to give me a call. I got a couple nice prop planes I can sell you and I have already tested them, … a lot.

Our club typically has ~ 27 jet guys. Based on what I have seen, we all have experienced some sort of turbine failure. I have either witnessed or help troubleshoot many of these. What is also common to our jet guys is they all seem to, at least outwardly, accept the fact that we are the beta testers. They never seem to be ranting on the INet or even at our gatherings. They frequently change brands and most are willing to own multiple brands at the same time. Guess we keep the good ones and the bad ones just tend to take care of themselves, etc. etc. Point being that; How we respond to a turbine failure is an attitude choice. Good attitudes seem to be catching. So are bad ones. Which one do you want to be viewed with? If you can't deal with maintaining a good attitude, then never buy a first year production model!

So when you are faced with an issue to be fixed, be thankful that the Barrys and Georges and other service guys are there. They to are only dealing with the products the manufacturers send to us for testing and the conditions we expose these products to. If you do not want to take the risks that goes with cutting edge technology and high-performance and the conditions we expose these products to, then you may want to reconsider what sport you really would enjoy.

DISCLAIMER: All this being said MAY not preclude me from initially being a bit POed when the next one dies!
Len Todd is online now  
Reply With Quote
Old 11-08-2018, 07:23 AM
  #21  
Auburn02
My Feedback: (1)
 
Join Date: May 2005
Posts: 574
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Barry, I have a fairly early serial # of this engine - if there's anything I can offer to help the process please feel free to PM me.
Auburn02 is offline  
Reply With Quote
Old 11-08-2018, 09:18 AM
  #22  
camss69
My Feedback: (46)
 
camss69's Avatar
 
Join Date: Jul 2002
Location: Folsom, CA
Posts: 1,356
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Mine may have been a casualty of this as well although mine had no visible damage. Mine lived for 4 minutes but happy to say Barry at Kingtech took care of it. Luckily mine was on the test stand and not in the plane on the maiden flight. Thankfully it was recommended to run it on the test stand before putting it in the plane.
camss69 is online now  
Reply With Quote
Old 11-08-2018, 12:34 PM
  #23  
Airforce7
My Feedback: (31)
 
Airforce7's Avatar
 
Join Date: Feb 2004
Location: Brentwood, CA
Posts: 997
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I have a K70G2 #179 in a TopRCModels cougar. I've had it for a year and has about 20 flights. This is my first KT turbine and it runs fantastic. Now I'm a bit concerned having read through this thread.

If I need to send it in for a checkup please let me know ASAP. I'll be happy to do that. Otherwise I will continue to fly with it in the near future.

Last edited by Airforce7; 11-08-2018 at 12:44 PM.
Airforce7 is offline  
Reply With Quote
Old 11-08-2018, 02:44 PM
  #24  
rhklenke
My Feedback: (24)
 
rhklenke's Avatar
 
Join Date: Jun 2002
Location: Richmond, VA
Posts: 5,673
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

As I mentioned above, I had an engine from another manufacturer that did the same thing *twice*. It came to pass that that engine developed a history of doing that, so when I sent mine in, it was repaired at no cost to me (*twice*). I did hear from other guys with that engine that the first few times it happened there was some push-back from the manufacturer that it was a user problem, not an engine problem. However, after the engines started coming back with the same issue, the manufacturer realized that it *was* an engine problem and they came out with a new compressor and started replacing the ones on the failed engines for no cost.

Different manufacturer, same issue and initial response. See Len's post above - it can happen to any of them...

If you want bullet-proof tanks, go with AMT's or old JetCat P-120's...

Bob
rhklenke is online now  
Reply With Quote
Old 11-08-2018, 02:50 PM
  #25  
Len Todd
 
Join Date: Jul 2012
Location: Baldwin, MI
Posts: 1,126
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

If you have a concern, your best bet is to call Barry and ask. When the bearings went out in my K-160 prematurely, my friend called about his K-160 and Barry told him to send it in. For us north of the Mason-Dixon, now is the time to send 'er in, if it needs work or modification. Don't forget to send the ECU with it.
Len Todd is online now  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service